aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-12 08:29:29 -0700
committerTim Orling <TicoTimo@gmail.com>2014-08-24 19:45:17 -0700
commit5d28f1866df12f9e66cbcf80b43e0918aa9095dc (patch)
tree0d6cb9cc1f64b906335669aa309d103aa45a9f7d
parent8d4d861d020c24384a953939a787cbacc20d51aa (diff)
downloadmeta-openembedded-contrib-5d28f1866df12f9e66cbcf80b43e0918aa9095dc.tar.gz
libclass-xsaccessor-perl: add 1.19
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libclass/libclass-xsaccessor-perl_1.19.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libclass/libclass-xsaccessor-perl_1.19.bb b/meta-perl/recipes-perl/libclass/libclass-xsaccessor-perl_1.19.bb
new file mode 100644
index 0000000000..64f4694233
--- /dev/null
+++ b/meta-perl/recipes-perl/libclass/libclass-xsaccessor-perl_1.19.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Class::XSAccessor - Generate fast XS accessors without runtime compilation"
+DESCRIPTION = "Class::XSAccessor implements fast read, write and read/write \
+accessors in XS. Additionally, it can provide predicates such as \
+\"has_foo()\" for testing whether the attribute \"foo\" exists in the object \
+(which is different from \"is defined within the object\"). It only works \
+with objects that are implemented as ordinary hashes."
+
+SECTION = "libs"
+
+HOMEPAGE = "https://metacpan.org/pod/Class-XSAccessor/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=173;endline=178;md5=191d949028e266de4be5f0364f547d32"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/S/SM/SMUELLER/Class-XSAccessor-${PV}.tar.gz"
+SRC_URI[md5sum] = "5c5dea74f00ad37c5119dd22b28a5563"
+SRC_URI[sha256sum] = "99c56b395f1239af19901f2feeb125d9ecb4e351a0d80daa9529211a4700a6f2"
+
+S = "${WORKDIR}/Class-XSAccessor-${PV}"
+
+inherit cpan
+
+DEPENDS_${PN} = " perl-module-time-hires-native \
+ perl-module-xsloader-native \
+"
+
+BBCLASSEXTEND = "native"