aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2014-08-19 14:28:31 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-21 21:35:07 +0200
commit6edd5b336455627f0540238d9d63e45d633cd249 (patch)
tree93135b9b58fceeebc1e60e023eb5fc855dc7d813
parent5e1098f2c2e1a553e9e816e12982190bb9bdf762 (diff)
downloadmeta-openembedded-contrib-6edd5b336455627f0540238d9d63e45d633cd249.tar.gz
numactl: fix the ptest
1. one test case is not installed 2. install a copy of numactl into ptest dir, since the test script is using the relative path to run numactl Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/numactl/numactl_2.0.9.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/numactl/numactl_2.0.9.bb b/meta-oe/recipes-support/numactl/numactl_2.0.9.bb
index bbb3393a4a..651277dab4 100644
--- a/meta-oe/recipes-support/numactl/numactl_2.0.9.bb
+++ b/meta-oe/recipes-support/numactl/numactl_2.0.9.bb
@@ -33,11 +33,12 @@ do_install_ptest() {
local test_binaries="checkaffinity checktopology distance \
ftok mbind_mig_pages migrate_pages move_pages mynode \
nodemap pagesize prefered printcpu randmap realloc_test \
- regress regress2 runltp shmtest tbitmap tshared"
+ regress regress2 runltp shmtest tbitmap tshared bind_range"
[ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
for i in $test_binaries; do
install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
done
install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
+ install -m 0755 ${B}/numactl ${D}${PTEST_PATH}/
}