aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Cavallini <m.cavallini@koansoftware.com>2021-10-18 16:22:47 +0200
committerKhem Raj <raj.khem@gmail.com>2021-10-18 09:55:55 -0700
commitf02b4a26e4a755311ab49c79f3efd3da4dffae71 (patch)
tree98ad62b9a70abc4aec18db14af6c3ddcf800d22a
parent8f640fb5da434dc26cffa05a4aae30219ffe9be0 (diff)
downloadmeta-openembedded-contrib-f02b4a26e4a755311ab49c79f3efd3da4dffae71.tar.gz
bluepy_git.bb: Added recipe for BluePy - Python interface to Bluetooth LE on Linux
Signed-off-by: Marco Cavallini <koansoftware@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/bluepy/bluepy_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
new file mode 100644
index 0000000000..651a752545
--- /dev/null
+++ b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Python interface to Bluetooth LE on Linux"
+HOMEPAGE = "https://github.com/IanHarvey/bluepy"
+SECTION = "devel/python"
+
+DEPENDS = "${PYTHON_PN} glib-2.0"
+RDEPENDS_${PN} = "bluez5"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+inherit setuptools3
+
+SRC_URI = "git://github.com/IanHarvey/bluepy.git;protocol=https;rev=7ad565231a97c304c0eff45f2649cd005e69db09"
+S = "${WORKDIR}/git"
+
+TARGET_CC_ARCH += "${LDFLAGS}" \ No newline at end of file