aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-10-11 17:18:38 -0700
committerTim Orling <ticotimo@gmail.com>2021-10-18 10:38:31 -0700
commit2831020b3eb6884bdf7613a146e035ef1b3e0097 (patch)
tree46b3a59aa2f5ea5beb004b4f71fcc2d0d819b324
parent25fe7751e8e95a4604fbcd062616fb5fedeaf1c4 (diff)
downloadmeta-openembedded-contrib-2831020b3eb6884bdf7613a146e035ef1b3e0097.tar.gz
gjs: upgrade 1.58.8 -> 1.70.0
Drop config.ac patch as build system is now meson Drop backported patch Use SPDX license identifier for LGPL-2.0-or-later License-Update: Clarified dependency licenses; remains MIT & LGPLv2+ Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs/0001-Disable-tests-on-host.patch33
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs/0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch77
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb (renamed from meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb)20
3 files changed, 6 insertions, 124 deletions
diff --git a/meta-gnome/recipes-gnome/gjs/gjs/0001-Disable-tests-on-host.patch b/meta-gnome/recipes-gnome/gjs/gjs/0001-Disable-tests-on-host.patch
deleted file mode 100644
index 0953214fbf..0000000000
--- a/meta-gnome/recipes-gnome/gjs/gjs/0001-Disable-tests-on-host.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 95379de2132786f855e8caec1fd5869225774d02 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
-Date: Sat, 18 May 2019 01:14:07 +0200
-Subject: [PATCH] Disable tests on host
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Upstream-Status: Inappropriate [OE-specific]
-
-Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
----
- configure.ac | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index fa4e136..056e96e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -335,9 +335,7 @@ AS_IF([test "x$with_dbus_tests" != "xno"], [
- ])
- AM_CONDITIONAL([DBUS_TESTS], [test "x$with_dbus_tests" != "xno"])
-
--AC_MSG_CHECKING([for a suitable UTF-8 locale to run the tests in])
--TESTS_LOCALE=$($srcdir/build/choose-tests-locale.sh)
--AC_MSG_RESULT([$TESTS_LOCALE])
-+TESTS_LOCALE=C
- AC_SUBST([TESTS_LOCALE])
-
- AC_SUBST([gjsjsdir], [\${datadir}/gjs-1.0])
---
-2.20.1
-
diff --git a/meta-gnome/recipes-gnome/gjs/gjs/0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch b/meta-gnome/recipes-gnome/gjs/gjs/0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch
deleted file mode 100644
index 6343a24a2d..0000000000
--- a/meta-gnome/recipes-gnome/gjs/gjs/0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From dae0055be61937fe70252f3f4ee09b355aba2b8f Mon Sep 17 00:00:00 2001
-From: Philip Chimento <philip.chimento@gmail.com>
-Date: Sun, 14 Feb 2021 12:20:09 -0800
-Subject: [PATCH] maint: Avoid g_once_init_enter error in GCC 11
-
-On platforms where g_once_init_enter() is defined to use C11 atomic
-builtins, passing a pointer to a volatile value is an error in GCC 11 and
-later, in C++.
-
-More info about the GCC change:
-https://gcc.gnu.org/bugzilla/show_bug.cgi?id=95378
-https://gcc.gnu.org/pipermail/gcc-patches/2020-June/548283.html
-
-However, it's my understanding that in modern C++ there is no longer a
-need to guard the initialization of these variables. Since C++11, static
-local variables in a function are guaranteed to be initialized only once,
-the first time control passes through that function. So we can just remove
-the g_once_init_enter guard.
-
-More info:
-https://en.cppreference.com/w/cpp/language/storage_duration#Static_local_variables
-
-Stack Overflow answers with quotations from the C++ standard:
-https://stackoverflow.com/a/58804/172999
-https://stackoverflow.com/a/8102145/172999
-
-Closes: #376
----
- gjs/error-types.cpp | 32 +++++++++++++-------------------
- 1 file changed, 13 insertions(+), 19 deletions(-)
-
-Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/gjs/-/commit/f02eaf3a9d3465915eb849428c2d9615e2184a4c]
-diff --git a/gjs/error-types.cpp b/gjs/error-types.cpp
-index 86cb878..5eba61b 100644
---- a/gjs/error-types.cpp
-+++ b/gjs/error-types.cpp
-@@ -31,24 +31,18 @@ G_DEFINE_QUARK(gjs-js-error-quark, gjs_js_error)
- // clang-format on
-
- GType gjs_js_error_get_type(void) {
-- static volatile GType g_type_id;
--
-- if (g_once_init_enter(&g_type_id)) {
-- static GEnumValue errors[] = {
-- { GJS_JS_ERROR_ERROR, "Error", "error" },
-- { GJS_JS_ERROR_EVAL_ERROR, "EvalError", "eval-error" },
-- { GJS_JS_ERROR_INTERNAL_ERROR, "InternalError", "internal-error" },
-- { GJS_JS_ERROR_RANGE_ERROR, "RangeError", "range-error" },
-- { GJS_JS_ERROR_REFERENCE_ERROR, "ReferenceError", "reference-error" },
-- { GJS_JS_ERROR_STOP_ITERATION, "StopIteration", "stop-iteration" },
-- { GJS_JS_ERROR_SYNTAX_ERROR, "SyntaxError", "syntax-error" },
-- { GJS_JS_ERROR_TYPE_ERROR, "TypeError", "type-error" },
-- { GJS_JS_ERROR_URI_ERROR, "URIError", "uri-error" },
-- { 0, nullptr, nullptr }
-- };
--
-- g_type_id = g_enum_register_static("GjsJSError", errors);
-- }
--
-+ static const GEnumValue errors[] = {
-+ {GJS_JS_ERROR_ERROR, "Error", "error"},
-+ {GJS_JS_ERROR_EVAL_ERROR, "EvalError", "eval-error"},
-+ {GJS_JS_ERROR_INTERNAL_ERROR, "InternalError", "internal-error"},
-+ {GJS_JS_ERROR_RANGE_ERROR, "RangeError", "range-error"},
-+ {GJS_JS_ERROR_REFERENCE_ERROR, "ReferenceError", "reference-error"},
-+ {GJS_JS_ERROR_STOP_ITERATION, "StopIteration", "stop-iteration"},
-+ {GJS_JS_ERROR_SYNTAX_ERROR, "SyntaxError", "syntax-error"},
-+ {GJS_JS_ERROR_TYPE_ERROR, "TypeError", "type-error"},
-+ {GJS_JS_ERROR_URI_ERROR, "URIError", "uri-error"},
-+ {0, nullptr, nullptr}};
-+ // Initialization of static local variable guaranteed only once in C++11
-+ static GType g_type_id = g_enum_register_static("GjsJSError", errors);
- return g_type_id;
- }
---
-2.31.1
-
diff --git a/meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb b/meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb
index 096e277bb4..7ffd611455 100644
--- a/meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb
+++ b/meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb
@@ -1,20 +1,18 @@
SUMMARY = "Javascript bindings for GNOME"
-LICENSE = "MIT & LGPLv2+"
+LICENSE = "MIT & LGPL-2.0-or-later"
LIC_FILES_CHKSUM = " \
- file://COPYING;md5=beb29cf17fabe736f0639b09ee6e76fa \
- file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7 \
+ file://COPYING;md5=8dcea832f6acf45d856abfeb2d51ec48 \
+ file://LICENSES/MIT.txt;md5=38aa75cf4c4c87f018227d5ec9638d75 \
+ file://LICENSES/LGPL-2.0-or-later.txt;md5=6d2d9952d88b50a51a5c73dc431d06c7 \
"
-GNOMEBASEBUILDCLASS = "autotools"
+GNOMEBASEBUILDCLASS = "meson"
DEPENDS = "mozjs gtk+3"
inherit gnomebase gsettings gobject-introspection vala gettext features_check upstream-version-is-even pkgconfig
-SRC_URI[archive.sha256sum] = "7fb3eb746c17363d9ee47f4a5d0bb048f0075611763eb0da11d85e0e57aff381"
-SRC_URI += "file://0001-Disable-tests-on-host.patch \
- file://0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch \
-"
+SRC_URI[archive.sha256sum] = "4b0629341a318a02374e113ab97f9a9f3325423269fc1e0b043a5ffb01861c5f"
# gobject-introspection is mandatory and cannot be configured
REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
@@ -25,12 +23,6 @@ EXTRA_OECONF = " \
--disable-installed-tests \
"
-do_configure:prepend() {
- # make configure find gobject-introspection test code. Although we set
- # --disable-installed-tests gjs builds them
- sed -i 's|:$GI_DATADIR|:${STAGING_DIR_NATIVE}$GI_DATADIR|g' ${S}/configure.ac
-}
-
FILES:${PN} += "${datadir}/gjs-1.0/lsan"
PACKAGES =+ "${PN}-valgrind"