aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-11-26 13:22:13 +0200
committerKhem Raj <raj.khem@gmail.com>2020-11-27 11:54:04 -0800
commiteed4c901afc1c5bb1e3ba687dfa29b612cfba2ab (patch)
tree5aac21e4740211624502a5a3278465cd58dc42de
parente3c9a42603af6f78e87236682bd709cc57f21bef (diff)
downloadmeta-openembedded-contrib-eed4c901afc1c5bb1e3ba687dfa29b612cfba2ab.tar.gz
python3-prettytable: Upgrade 1.0.1 -> 2.0.0
Upgrade to release 2.0.0: - Add tbody and thead tags - Add add_rows to add several rows at once - Add Python 3.10-dev to CI Tests - Stop testing on Travis CI due to new open-source limitations - Move to src/ and tests/ layout - Drop support for EOL Python 2.7 and 3.5 - Fix padding_width = 0 - Don't create universal wheel for Python 2 (and 3) - Fix docs to match code: from_cursor -> from_db_cursor - readme: update function name in example Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-prettytable_2.0.0.bb (renamed from meta-python/recipes-devtools/python/python3-prettytable_1.0.1.bb)5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prettytable_1.0.1.bb b/meta-python/recipes-devtools/python/python3-prettytable_2.0.0.bb
index 79341b9d29..3563bfa113 100644
--- a/meta-python/recipes-devtools/python/python3-prettytable_1.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-prettytable_2.0.0.bb
@@ -3,8 +3,7 @@ HOMEPAGE = "http://code.google.com/p/prettytable"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=c9a6829fcd174d9535b46211917c7671"
-SRC_URI[md5sum] = "b5bd0acec56ae7ccf5ac22d3f671c3a7"
-SRC_URI[sha256sum] = "6bb7f539903cb031fecb855b615cbcac8cd245ebc6fa51c6e23ab3386db89771"
+SRC_URI[sha256sum] = "e37acd91976fe6119172771520e58d1742c8479703489321dc1d9c85e7259922"
do_install_append() {
perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
@@ -36,5 +35,5 @@ RDEPENDS_${PN}-ptest += " \
"
do_install_ptest() {
- cp -f ${S}/prettytable_test.py ${D}${PTEST_PATH}/
+ cp -f ${S}/tests/test_prettytable.py ${D}${PTEST_PATH}/
}