aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-11-26 13:22:12 +0200
committerKhem Raj <raj.khem@gmail.com>2020-11-27 11:54:04 -0800
commite3c9a42603af6f78e87236682bd709cc57f21bef (patch)
treedd0b7ca238e866781cdcac5d3bb32ff9ae532c28
parent515f9767121105bdce64f13577d91f16b153cb4d (diff)
downloadmeta-openembedded-contrib-e3c9a42603af6f78e87236682bd709cc57f21bef.tar.gz
python3-ansi2html: Upgrade 1.5.2 -> 1.6.0
Add native setuptools-scm and toml to the dependencies. Upgrade to release 1.6.0: - Add support for vt100 box drawing mode and high-intensity ansi codes - Fix undefined behavior with linkify when same url is repeated in same line - Prune CSS classes from output that are not used - Update style.py - Give more useful TaskWarrior example - Fix handling cursor move up with unique and empty lines - enable python 3 input decoding - Fix missing color CSS definitions - Prevent IndexError while handling CursorMoveUp - added setup.cfg - fix long lines - Started to implement LaTeX support - add option --title for filling in the title - add empty title element to head section in html output - added 2 color-schemes (solarized, osx). improved optparse handling schemes. - added support to select a color-scheme. added schemes 'xterm' and 'xterm... - Improve Makefile - Add and ship AsciiDoc manpage, improve --help, add --version - Fix README example to not produce unwanted spaces - Add missing license headers - Fix line handling - Add support for previously unhandled ANSI codes, improve approach on handling color state - Fix italic to be font-style (rather than font-weight) - Stop adding unwanted spaces - Fix writing to sys.stdout.buffer - Add convenience Makefile - Fix some bugs - add --inline style - Fix UnicodeDecodeError exception when Unicode characters appear in input Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-ansi2html_1.6.0.bb (renamed from meta-python/recipes-devtools/python/python3-ansi2html_1.5.2.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ansi2html_1.5.2.bb b/meta-python/recipes-devtools/python/python3-ansi2html_1.6.0.bb
index 8e586ea3e8..d31448d6a8 100644
--- a/meta-python/recipes-devtools/python/python3-ansi2html_1.5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-ansi2html_1.6.0.bb
@@ -5,9 +5,9 @@ LICENSE = "GPLv3"
PYPI_PACKAGE = "ansi2html"
-SRC_URI[md5sum] = "52d6085ad1c5970082ea5305a26af981"
-SRC_URI[sha256sum] = "96ae85ae7b26b7da674d87de2870ba4d1964bca733ae4614587080b6358c3ba9"
+SRC_URI[sha256sum] = "0f124ea7efcf3f24f1f9398e527e688c9ae6eab26b0b84e1299ef7f94d92c596"
inherit pypi setuptools3
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native ${PYTHON_PN}-toml-native"
RDEPENDS_${PN} = "${PYTHON_PN}-six"