aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregory Anders <greg@gpanders.com>2020-11-09 09:57:46 -0700
committerKhem Raj <raj.khem@gmail.com>2020-11-12 12:44:25 -0800
commitd1c2512eeeab69976bc1214ce988193c5eeb634c (patch)
tree560275d11cb2ed243b8fd7904289398af5c74513
parentf3a23389784b4e707d2485aea04067fed517fec4 (diff)
downloadmeta-openembedded-contrib-d1c2512eeeab69976bc1214ce988193c5eeb634c.tar.gz
Add python3-transitions
Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-transitions_0.8.4.bb11
2 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 6a30619866..248abaff7b 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -425,6 +425,7 @@ RDEPENDS_packagegroup-meta-python3 = "\
python3-pycurl \
gyp \
python3-jsonref \
+ python3-transitions \
"
RDEPENDS_packagegroup-meta-python3-extended = "\
diff --git a/meta-python/recipes-devtools/python/python3-transitions_0.8.4.bb b/meta-python/recipes-devtools/python/python3-transitions_0.8.4.bb
new file mode 100644
index 0000000000..3da97ef95e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-transitions_0.8.4.bb
@@ -0,0 +1,11 @@
+inherit pypi setuptools3
+
+SUMMARY = "A lightweight, object-oriented Python state machine implementation with many extensions."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=de0a0876a688a4483bfafa764773ab39"
+
+SRC_URI = "https://files.pythonhosted.org/packages/32/32/305845f95f98b505e641aa3fc135b0a9747befcff06223a541d2aa388d47/transitions-${PV}.tar.gz"
+SRC_URI[md5sum] = "ef07ea90015a296653a4b095837b0354"
+SRC_URI[sha256sum] = "9a2841b24789dfd345267cb92e26b79da75fd03f6021d1a5222c71b5c9ae3c16"
+
+RDEPENDS_${PN} += "python3-six"