aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-11-21 15:56:21 -0800
committerKhem Raj <raj.khem@gmail.com>2020-11-23 13:00:55 -0800
commitcc0e096f0d0d4cd044a85a0240d7c77af7befda2 (patch)
tree5c46e95c9c84e2bd7c89e93917606a2f5879c373
parentb2e6fa5b7bd7335d41d3cf6a85e1a19e02aa5657 (diff)
downloadmeta-openembedded-contrib-cc0e096f0d0d4cd044a85a0240d7c77af7befda2.tar.gz
python3-hypothesis: Add recipe
Its needed by python3-numpy pytests Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-hypothesis_5.41.3.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-hypothesis_5.41.3.bb b/meta-python/recipes-devtools/python/python3-hypothesis_5.41.3.bb
new file mode 100644
index 0000000000..b7bf15c31e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-hypothesis_5.41.3.bb
@@ -0,0 +1,14 @@
+SUMMARY = "A library for property-based testing"
+HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
+
+PYPI_PACKAGE = "hypothesis"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "6a3471ff74864ab04a0650c75500ef15f2f4a901d49ccbb7cbec668365736688"
+
+RDEPENDS_${PN} += "python3-core"
+
+BBCLASSEXTEND = "native nativesdk"