aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2020-11-24 07:49:04 -0500
committerKhem Raj <raj.khem@gmail.com>2020-11-24 16:01:53 -0800
commit51c495772d3186ff7625675c83547eb7410db57f (patch)
tree7b38ca6bd53e1569564848b82677b86b171ca9c7
parentffafb00e45ad693da27662f13976f6a8247820c6 (diff)
downloadmeta-openembedded-contrib-51c495772d3186ff7625675c83547eb7410db57f.tar.gz
python3-markupsafe: Fix ptest RDEPENDS and installation
markupsafe's ptest is failing when running meta-python-ptest-image. This is because python3-markupsafe is in oe-core, but the ptests are disabled and so do_install_ptest doesn't actually install them when using the meta-python bbappend for the recipe. This patch adds do_install_ptest and the ptest RDEPENDS to the meta-python version of the recipe so that this works. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend b/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend
index 91814e6cde..abfda60658 100644
--- a/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend
+++ b/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend
@@ -1,2 +1,12 @@
# Main recipe was moved to oe-core, but with ptest disabled
inherit ${@bb.utils.filter('DISTRO_FEATURES', 'ptest', d)}
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+