aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Blanchard <anton@ozlabs.org>2021-08-17 21:04:37 +1000
committerKhem Raj <raj.khem@gmail.com>2021-08-19 09:58:56 -0700
commit7982a1260fa16832d9a8ec89c4fa36c64d5c96b4 (patch)
tree490417a722009ee44bc846a399cc1d45275086e1
parent8deb9e96df95372d72b6f682864c887ef39a4dba (diff)
downloadmeta-openembedded-contrib-7982a1260fa16832d9a8ec89c4fa36c64d5c96b4.tar.gz
cereal: Use GNUInstallDirs instead of hard wiring install directories
On a multilib setup cmake files should go into lib64. Signed-off-by: Anton Blanchard <anton@ozlabs.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libcereal/libcereal/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch37
-rw-r--r--meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb4
2 files changed, 40 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libcereal/libcereal/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch b/meta-oe/recipes-support/libcereal/libcereal/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch
new file mode 100644
index 0000000000..93114dadd6
--- /dev/null
+++ b/meta-oe/recipes-support/libcereal/libcereal/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch
@@ -0,0 +1,37 @@
+From c9e60ed064aa2938f71f2cacf79f0bb337812bf8 Mon Sep 17 00:00:00 2001
+From: Anton Blanchard <anton@ozlabs.org>
+Date: Tue, 17 Aug 2021 09:32:43 +1000
+Subject: [PATCH] Use GNUInstallDirs instead of hard wiring install directories
+
+On a multilib setup cmake files should go into lib64.
+
+Upstream-Status: Submitted [https://github.com/USCiLab/cereal/pull/710]
+---
+ CMakeLists.txt | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b97c1f59..ad574290 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -70,14 +70,15 @@ endif()
+
+ option(CEREAL_INSTALL "Generate the install target" ${CEREAL_MASTER_PROJECT})
+ if(CEREAL_INSTALL)
++ include(GNUInstallDirs)
+ include(CMakePackageConfigHelpers)
+
+ install(TARGETS cereal EXPORT ${PROJECT_NAME}Targets)
+- install(DIRECTORY include/cereal DESTINATION include)
++ install(DIRECTORY include/cereal DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+ set(configFile ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}Config.cmake)
+ set(versionFile ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}ConfigVersion.cmake)
+- set(configInstallDestination lib/cmake/${PROJECT_NAME})
++ set(configInstallDestination ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME})
+
+ configure_package_config_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/Config.cmake.in
+--
+2.31.1
+
diff --git a/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb b/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb
index 26b27fa6e0..6498bb367a 100644
--- a/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb
+++ b/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb
@@ -16,7 +16,9 @@ PROVIDES += "${PN}-dev"
PV .= "+git${SRCPV}"
SRCREV = "64f50dbd5cecdaba785217e2b0aeea3a4f1cdfab"
-SRC_URI = "git://github.com/USCiLab/cereal.git"
+SRC_URI = "git://github.com/USCiLab/cereal.git \
+ file://0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch \
+ "
S = "${WORKDIR}/git"