aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaus Stovgaard <clst@ambu.com>2021-12-21 22:49:14 +0100
committerKhem Raj <raj.khem@gmail.com>2021-12-21 18:49:37 -0800
commite597752612dffceb610015577a5ef248c7b3597e (patch)
treefc65f86261e220d7baf21e5fd3b8a66b252f4f0f
parent83bb0c483f9021374187fc54bee0234656832cf8 (diff)
downloadmeta-openembedded-contrib-e597752612dffceb610015577a5ef248c7b3597e.tar.gz
Add pycups - python bindings for CUPS
Used for access cups and control printers from python. Placed in meta-oe together with the rest of printing support, as tools like system-config-printer depend on pycups. Signed-off-by: Claus Stovgaard <clst@ambu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python3-pycups_2.0.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python3-pycups_2.0.1.bb b/meta-oe/recipes-devtools/python/python3-pycups_2.0.1.bb
new file mode 100644
index 0000000000..dd00f444ed
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python3-pycups_2.0.1.bb
@@ -0,0 +1,19 @@
+# Python bindings for libcups, from the CUPS project.
+#
+# Copyright (c) Ambu A/S - All rights reserved
+# SPDX-License-Identifier: MIT
+#
+# Author(s)
+# clst@ambu.com (Claus Stovgaard)
+#
+
+DESCRIPTION = "pycups - CUPS bindings for Python"
+HOMEPAGE = "https://github.com/OpenPrinting/pycups"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+DEPENDS += "cups"
+
+# See https://pypi.org/project/pycups/ for data
+SRC_URI[sha256sum] = "57434ce5f62548eb12949ca8217f066f4eeb21a5d6ab8b13471dce350e380c90"
+
+inherit pypi setuptools3 \ No newline at end of file