aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2022-11-10 16:36:13 +0800
committerKhem Raj <raj.khem@gmail.com>2022-11-10 10:41:35 -0800
commit3497108129d6316ee8695a91bc8b24e28c69352a (patch)
tree341e8560616efef698d274d7769347e52d61434a
parent8df920252454762a1c84e2d899c8971dd2ca7342 (diff)
downloadmeta-openembedded-contrib-3497108129d6316ee8695a91bc8b24e28c69352a.tar.gz
waylandpp: add opengl to REQUIRED_DISTRO_FEATURES
waylandpp needs virtual/libgles2 which is available when opengl is enabled in mesa recipe, so also add the check for waylandpp. Fixes: ERROR: Nothing PROVIDES 'virtual/libgles2' (but /build/layers/meta-openembedded/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb DEPENDS on or otherwise requires it). Close matches: virtual/imlib2 virtual/libc virtual/libsdl2 ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'waylandpp', 'virtual/libgles2'] Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb b/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
index f075f2a3ae..0deed332c6 100644
--- a/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
+++ b/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
@@ -10,7 +10,9 @@ DEPENDS:append:class-target = " waylandpp-native wayland virtual/egl virtual/lib
S = "${WORKDIR}/git"
SRCREV = "4321ed5c7b4bffa41b8a2a13dc7f3ece1191f4f3"
-inherit cmake pkgconfig
+inherit cmake pkgconfig features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
EXTRA_OECMAKE:class-native = " \
-DBUILD_SCANNER=ON \