aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-03 16:42:30 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-05 18:42:55 -0700
commit6069a6d3fe80d177e9ddaf85d5251a7403e787a9 (patch)
tree614a556d33417bcc08b38e3022d0fcf96d77bcec
parent8eb63242148d1c95dec2398c73b166f8482f9f6e (diff)
downloadmeta-openembedded-contrib-6069a6d3fe80d177e9ddaf85d5251a7403e787a9.tar.gz
python3-editor: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-editor.inc9
-rw-r--r--meta-python/recipes-devtools/python/python3-editor_1.0.4.bb10
2 files changed, 9 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-editor.inc b/meta-python/recipes-devtools/python/python-editor.inc
deleted file mode 100644
index 734ce2bd7a..0000000000
--- a/meta-python/recipes-devtools/python/python-editor.inc
+++ /dev/null
@@ -1,9 +0,0 @@
-DESCRIPTION = "Programmatically open and editor, capture the result"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
-
-SRC_URI[md5sum] = "0e52648a4a6e7c89e3be44e9456530b4"
-SRC_URI[sha256sum] = "51fda6bcc5ddbbb7063b2af7509e43bd84bfc32a4ff71349ec7847713882327b"
-
-PYPI_PACKAGE = "python-editor"
-
diff --git a/meta-python/recipes-devtools/python/python3-editor_1.0.4.bb b/meta-python/recipes-devtools/python/python3-editor_1.0.4.bb
index 8ad2b869d9..c7a6cd8f0b 100644
--- a/meta-python/recipes-devtools/python/python3-editor_1.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-editor_1.0.4.bb
@@ -1,2 +1,10 @@
+DESCRIPTION = "Programmatically open and editor, capture the result"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+SRC_URI[md5sum] = "0e52648a4a6e7c89e3be44e9456530b4"
+SRC_URI[sha256sum] = "51fda6bcc5ddbbb7063b2af7509e43bd84bfc32a4ff71349ec7847713882327b"
+
+PYPI_PACKAGE = "python-editor"
+
inherit pypi setuptools3
-require python-editor.inc