aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-11-29 11:37:11 -0800
committerTim Orling <ticotimo@gmail.com>2023-12-05 06:58:40 -0800
commite170f9cf6516bcdcd7862dedd9977974cf330abb (patch)
tree3ad0e7a2e191bba4403c86de6d9475d1eff022fb
parentf400442e66586816f6dfd6119533241a2d20b4b5 (diff)
downloadmeta-openembedded-contrib-e170f9cf6516bcdcd7862dedd9977974cf330abb.tar.gz
[WIP] python3-pytest-examples: add v0.0.10
Dependency for python3-pydantic ptests. Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-examples_0.0.10.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-examples_0.0.10.bb b/meta-python/recipes-devtools/python/python3-pytest-examples_0.0.10.bb
new file mode 100644
index 0000000000..3ddf9ede44
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-examples_0.0.10.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Pytest plugin for testing examples in docstrings and markdown files."
+DESCRIPTION = "pytest-examples can:\
+\
+lint code examples using ruff and black\
+run code examples\
+run code examples and check print statements are inlined correctly in the code\
+It can also update code examples in place to format them and insert or update \
+print statements."
+HOMEPAGE = "https://github.com/pydantic/pytest-examples"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4914bbb433a7975b6b5c5f1bb48bb9d0"
+
+SRC_URI[sha256sum] = "5d34d22e689aca2bbad8dd6b7cdcc9d0107e2942853b3154f3a3c68d145d91c5"
+
+inherit pypi python_hatchling
+
+S = "${WORKDIR}/pytest_examples-${PV}"
+PYPI_ARCHIVE_NAME = "pytest_examples-${PV}.${PYPI_PACKAGE_EXT}"
+
+RDEPENDS:${PN} += "\
+ python3-black \
+ python3-ruff \
+ "