aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:47 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:39 -0800
commit1c9b76323d8359c2a6347ab383812b00bd09b411 (patch)
treeac5443eb8a6d02fd3613c462dfd07b8411f7264b
parent52f5ec0d69b7e9d51646a181c7c498a22a8d2fb2 (diff)
downloadmeta-openembedded-contrib-1c9b76323d8359c2a6347ab383812b00bd09b411.tar.gz
python3-typeguard: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard_4.1.5.bb7
2 files changed, 5 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typeguard/run-ptest b/meta-python/recipes-devtools/python/python3-typeguard/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-typeguard/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-typeguard/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-typeguard_4.1.5.bb b/meta-python/recipes-devtools/python/python3-typeguard_4.1.5.bb
index 53a02dc4bc..000620ef73 100644
--- a/meta-python/recipes-devtools/python/python3-typeguard_4.1.5.bb
+++ b/meta-python/recipes-devtools/python/python3-typeguard_4.1.5.bb
@@ -17,9 +17,10 @@ RDEPENDS:${PN} += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-typing-extensions \
- ${PYTHON_PN}-unixadmin \
+ python3-pytest \
+ python3-typing-extensions \
+ python3-unittest-automake-output \
+ python3-unixadmin \
"
do_install_ptest() {