aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:34 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:37 -0800
commit0a982fba812243058a81a42d3e586b112376c17c (patch)
tree3f3b0f4085a8ae33368bd4d64e718b320d300042
parenta99a06c9ede8c1098ea9b8f583cdaa8b4a895959 (diff)
downloadmeta-openembedded-contrib-0a982fba812243058a81a42d3e586b112376c17c.tar.gz
python3-inflection: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 * Fix some _ vs - errors Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-inflection/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb5
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-inflection/run-ptest b/meta-python/recipes-devtools/python/python3-inflection/run-ptest
index 0caffb794c..f1c8729f0e 100644
--- a/meta-python/recipes-devtools/python/python3-inflection/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-inflection/run-ptest
@@ -1,4 +1,4 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO test_inflection.py | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb b/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
index ea3b76d511..dbde8963e6 100644
--- a/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
@@ -14,7 +14,8 @@ SRC_URI +=" \
"
RDEPENDS:${PN}_ptest +=" \
- ${PYTHON_PN}_pytest \
+ python3_pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {
@@ -22,6 +23,6 @@ do_install_ptest() {
}
-RDEPENDS:${PN} += "${PYTHON_PN}-pytest"
+RDEPENDS:${PN} += "python3-pytest"
BBCLASSEXTEND = "native nativesdk"