aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2023-11-30 07:57:20 +0100
committerKhem Raj <raj.khem@gmail.com>2023-11-29 23:40:10 -0800
commiteeb57e1e8a2355a5eac1fa662fd97fe3930762d4 (patch)
tree1b6da0c39cfee4d6353d83157e3bc0ba84269d46
parent6fbe5001895a132644665fafa8b1676507023b90 (diff)
downloadmeta-openembedded-contrib-eeb57e1e8a2355a5eac1fa662fd97fe3930762d4.tar.gz
libcacard: set meson version based on PV
Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/spice/libcacard/0001-meson.build-set-hardcoded-version-string.patch34
-rw-r--r--meta-networking/recipes-support/spice/libcacard_2.8.1.bb9
2 files changed, 5 insertions, 38 deletions
diff --git a/meta-networking/recipes-support/spice/libcacard/0001-meson.build-set-hardcoded-version-string.patch b/meta-networking/recipes-support/spice/libcacard/0001-meson.build-set-hardcoded-version-string.patch
deleted file mode 100644
index b9d31c4584..0000000000
--- a/meta-networking/recipes-support/spice/libcacard/0001-meson.build-set-hardcoded-version-string.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From dbfc08b9dc879e21bfacbd153948d21db36d50cd Mon Sep 17 00:00:00 2001
-From: Markus Volk <f_l_k@t-online.de>
-Date: Thu, 23 Nov 2023 13:20:40 +0100
-Subject: [PATCH] meson.build: set hardcoded version string
-
-Signed-off-by: Markus Volk <f_l_k@t-online.de>
-
-This fixes version string in the pkgconfig file and thus unbreaks spice build
-| spice-common| Run-time dependency libcacard found: NO
-|
-| ../git/subprojects/spice-common/meson.build:144:16: ERROR: Dependency lookup for libcacard with method 'pkgconfig' failed: Invalid version, need 'libcacard' ['>= 2.5.1'] found 'UNKNOWN'.
-|
-| A full log can be found at /home/flk/poky/build/tmp/work/corei7-64-poky-linux/spice/0.15.2/build/meson-logs/meson-log.txt
-| ERROR: meson failed
-
-Upstream-Status: Inappropriate [oe-specific]
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 9cfe248..00745e5 100644
---- a/meson.build
-+++ b/meson.build
-@@ -1,5 +1,5 @@
- project('libcacard', 'c', 'cpp',
-- version: run_command('build-aux/git-version-gen', '@0@/.tarball-version'.format(meson.source_root()), check: true).stdout().strip(),
-+ version: '2.8.1',
- license: 'LGPLv2.1',
- default_options: ['warning_level=2'],
- )
---
-2.42.0
-
diff --git a/meta-networking/recipes-support/spice/libcacard_2.8.1.bb b/meta-networking/recipes-support/spice/libcacard_2.8.1.bb
index 44cccba9d1..65f2f80ace 100644
--- a/meta-networking/recipes-support/spice/libcacard_2.8.1.bb
+++ b/meta-networking/recipes-support/spice/libcacard_2.8.1.bb
@@ -6,11 +6,12 @@ DEPENDS = "glib-2.0 pcsc-lite nss"
SRCREV = "7b07684ea6698d4885ff2062350ad8798a04de42"
-SRC_URI = " \
- git://gitlab.freedesktop.org/spice/libcacard.git;protocol=https;branch=master \
- file://0001-meson.build-set-hardcoded-version-string.patch \
-"
+SRC_URI = "git://gitlab.freedesktop.org/spice/libcacard.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
inherit meson pkgconfig
+
+do_configure:prepend() {
+ echo ${PV} > ${S}/.tarball-version
+}