aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-11-29 08:47:46 -0800
committerTim Orling <ticotimo@gmail.com>2023-12-05 11:39:26 -0800
commite6ebdfcb815cafccc8faf3d3722ea0e1ae6eea30 (patch)
treecd146ed4ef0c3ef02e5b1c41b051cf5e1b6dbeac
parente4660bc7f55d5e9eaa76f27d39f20d4fcb762689 (diff)
downloadmeta-openembedded-contrib-e6ebdfcb815cafccc8faf3d3722ea0e1ae6eea30.tar.gz
python3-dirty-equals: add v0.7.1
Dependency for python3-pydantic-core ptests. """ dirty-equals is a python library that (mis)uses the __eq__ method to make python code (generally unit tests) more declarative and therefore easier to read and write. dirty-equals can be used in whatever context you like, but it comes into its own when writing unit tests for applications where you're commonly checking the response to API calls and the contents of a database. Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb b/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb
new file mode 100644
index 0000000000..ea9303b17e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Doing dirty (but extremely useful) things with equals."
+DESCRIPTION = "dirty-equals is a python library that (mis)uses the \
+__eq__ method to make python code (generally unit tests) more \
+declarative and therefore easier to read and write.\
+\
+dirty-equals can be used in whatever context you like, but it comes \
+into its own when writing unit tests for applications where you're \
+commonly checking the response to API calls and the contents of a database."
+HOMEPAGE = "https://github.com/samuelcolvin/dirty-equals"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c"
+
+SRC_URI[sha256sum] = "a580513f3285e93656a770a04e428f8bfc513848877bf278282dbfbb907fdbb4"
+
+S = "${WORKDIR}/dirty_equals-${PV}"
+
+inherit pypi python_hatchling
+
+PYPI_PACKAGE = "dirty_equals"
+
+RDEPENDS:${PN} += "python3-pytz"