aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-11-28 16:26:29 -0800
committerTim Orling <ticotimo@gmail.com>2023-12-05 11:39:12 -0800
commite4660bc7f55d5e9eaa76f27d39f20d4fcb762689 (patch)
treef2556862a588632be4c68635aae2f78990fd5ea5
parent7297f8648cff813d9b0211ad5f17d38c2d56b10e (diff)
downloadmeta-openembedded-contrib-e4660bc7f55d5e9eaa76f27d39f20d4fcb762689.tar.gz
python3-pydantic: fix RDEPENDS
* Newer python3-pydantic offloaded some of its code to python3-pydantic-core * Add python3-annotated-types to RDEPENDS. * Add DESCRIPTION and trim SUMMARY. Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb b/meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb
index 3750d49a97..226c58e876 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb
@@ -1,4 +1,10 @@
-SUMMARY = "Data validation and settings management using Python type hinting"
+SUMMARY = "Data validation using Python type hinting"
+DESCRIPTION = "Data validation and settings management using Python \
+type hints.\
+\
+Fast and extensible, Pydantic plays nicely with your linters/IDE/brain. \
+Define how data should be in pure, canonical Python 3.7+; validate it with \
+Pydantic."
HOMEPAGE = "https://github.com/samuelcolvin/pydantic"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=09280955509d1c4ca14bae02f21d49a6"
@@ -10,6 +16,7 @@ SRC_URI[sha256sum] = "ff177ba64c6faf73d7afa2e8cad38fd456c0dbe01c9954e71038001cd1
DEPENDS += "python3-hatch-fancy-pypi-readme-native"
RDEPENDS:${PN} += "\
+ python3-annotated-types \
python3-core \
python3-datetime \
python3-image \
@@ -19,5 +26,6 @@ RDEPENDS:${PN} += "\
python3-netclient \
python3-numbers \
python3-profile \
+ python3-pydantic-core \
python3-typing-extensions \
"