aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-16 12:05:24 -0800
committerTim Orling <tim.orling@konsulko.com>2024-02-16 12:30:47 -0800
commit9bad15ac1b99a3c47cf99d426ebaff4e05cc324f (patch)
treeabed57f2b38f5faefba35ee079912b8fcaea9070
parent6950d4911ce42ed639b09da6f6387378cb01e135 (diff)
downloadmeta-openembedded-contrib-9bad15ac1b99a3c47cf99d426ebaff4e05cc324f.tar.gz
python3-pyroute2: switch to pytest --automake
* Sort RDEPENDS for ptest alphabetically Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pyroute2/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb3
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest b/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest
index ea429ba21e..f1c8729f0e 100644
--- a/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest
@@ -1,4 +1,4 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb b/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb
index 6b340a18ce..740a6d7f73 100644
--- a/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb
+++ b/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb
@@ -27,9 +27,10 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- python3-pytest \
python3-fcntl \
+ python3-pytest \
python3-sqlite3 \
+ python3-unittest-automake-output \
"
do_install_ptest() {