aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-16 12:11:49 -0800
committerTim Orling <tim.orling@konsulko.com>2024-02-16 12:30:47 -0800
commit9b120060429e1c7eb706fad98f84716dc2d916a7 (patch)
tree1875f371c5e5b10d32443426f68accc8e2f7f170
parent6fbe1dfeee2f178f7adc7d5f83fd0cc8bdb1c8a3 (diff)
downloadmeta-openembedded-contrib-9b120060429e1c7eb706fad98f84716dc2d916a7.tar.gz
python3-yarl: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-yarl/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-yarl_1.9.4.bb13
2 files changed, 8 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yarl/run-ptest b/meta-python/recipes-devtools/python/python3-yarl/run-ptest
index 3385d68939..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-yarl/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-yarl/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-yarl_1.9.4.bb b/meta-python/recipes-devtools/python/python3-yarl_1.9.4.bb
index d9fe4c0c4c..29897b7f1c 100644
--- a/meta-python/recipes-devtools/python/python3-yarl_1.9.4.bb
+++ b/meta-python/recipes-devtools/python/python3-yarl_1.9.4.bb
@@ -12,18 +12,19 @@ PYPI_PACKAGE = "yarl"
inherit pypi ptest python_setuptools_build_meta
DEPENDS += " \
- ${PYTHON_PN}-expandvars-native \
- ${PYTHON_PN}-cython-native \
+ python3-expandvars-native \
+ python3-cython-native \
"
RDEPENDS:${PN} = "\
- ${PYTHON_PN}-multidict \
- ${PYTHON_PN}-idna \
- ${PYTHON_PN}-io \
+ python3-multidict \
+ python3-idna \
+ python3-io \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {