aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-16 12:04:14 -0800
committerTim Orling <tim.orling@konsulko.com>2024-02-16 12:30:47 -0800
commit7f7291aafbbbdd842bb9272b8a0109eef9d0602a (patch)
tree800672609d2c0f748ea234fba7515c18b2b8c655
parentac22dd50f5cb8c64e666eca007f04d753ef4747e (diff)
downloadmeta-openembedded-contrib-7f7291aafbbbdd842bb9272b8a0109eef9d0602a.tar.gz
python3-gunicorn: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-gunicorn/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-gunicorn_21.2.0.bb9
2 files changed, 6 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest b/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest
index 98d73fa037..5ca7e26e8a 100644
--- a/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest
@@ -4,4 +4,4 @@
# ptests to work, so make sure there's at least one nameserver line
echo "nameserver 8.8.8.8" >> /etc/resolv.conf
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-gunicorn_21.2.0.bb b/meta-python/recipes-devtools/python/python3-gunicorn_21.2.0.bb
index d765c8fd05..9fd601c999 100644
--- a/meta-python/recipes-devtools/python/python3-gunicorn_21.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-gunicorn_21.2.0.bb
@@ -12,9 +12,10 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-eventlet \
- ${PYTHON_PN}-gevent \
- ${PYTHON_PN}-pytest \
+ python3-eventlet \
+ python3-gevent \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {
@@ -22,4 +23,4 @@ do_install_ptest() {
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
-RDEPENDS:${PN} += "${PYTHON_PN}-setuptools ${PYTHON_PN}-fcntl"
+RDEPENDS:${PN} += "python3-setuptools python3-fcntl"