aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-16 11:58:44 -0800
committerTim Orling <tim.orling@konsulko.com>2024-02-16 12:30:47 -0800
commit4fa3f03f217763b1be77e0dc696cf95b1886083e (patch)
tree66c6a0259f648d1400448b93da6615ca51ee744c
parentad11e168230eecd04196c2b16e2b192037825a7e (diff)
downloadmeta-openembedded-contrib-4fa3f03f217763b1be77e0dc696cf95b1886083e.tar.gz
python3-whoosh: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 * Sort RDEPENDS for ptest alphabetically Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb19
2 files changed, 11 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-whoosh/run-ptest b/meta-python/recipes-devtools/python/python3-whoosh/run-ptest
index 3385d68939..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-whoosh/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
index ed2a6d423f..38d3e1cecd 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
+++ b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
@@ -16,13 +16,13 @@ PYPI_PACKAGE_EXT = "zip"
inherit ptest pypi setuptools3
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-email \
- ${PYTHON_PN}-multiprocessing \
- ${PYTHON_PN}-netclient \
- ${PYTHON_PN}-numbers \
- ${PYTHON_PN}-pickle \
- ${PYTHON_PN}-shell \
- ${PYTHON_PN}-stringold \
+ python3-email \
+ python3-multiprocessing \
+ python3-netclient \
+ python3-numbers \
+ python3-pickle \
+ python3-shell \
+ python3-stringold \
"
SRC_URI += " \
@@ -30,8 +30,9 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-fcntl \
+ python3-fcntl \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {