aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-16 11:30:02 -0800
committerTim Orling <tim.orling@konsulko.com>2024-02-16 12:30:46 -0800
commit2af9ca84e8505fa5657c61b932daa5bed8947eac (patch)
tree844079280f8469c834bbf801acd1364b05d22116
parent169b7ba5dd117b09906920c329c176635625df9a (diff)
downloadmeta-openembedded-contrib-2af9ca84e8505fa5657c61b932daa5bed8947eac.tar.gz
python3-u-msgpack-python: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb5
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest b/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest
index 7110f6bc40..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO test_umsgpack.py| sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb
index 8baedcb951..6cde243fe8 100644
--- a/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb
@@ -12,7 +12,8 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {
@@ -20,7 +21,7 @@ do_install_ptest() {
}
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-datetime \
+ python3-datetime \
"
BBCLASSEXTEND = "native nativesdk"