aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-16 12:24:41 -0800
committerTim Orling <tim.orling@konsulko.com>2024-02-16 15:28:56 -0800
commit0784edb157890f2c4b99a84fcd9a1c1b2ef29661 (patch)
treeb067004617bb7860c89e1ae44bc1a3cb78f67c48
parent55785398d9c181fe5b71d57ba8237e759c2054e7 (diff)
downloadmeta-openembedded-contrib-0784edb157890f2c4b99a84fcd9a1c1b2ef29661.tar.gz
python3-cachetools: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools_5.3.2.bb5
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachetools/run-ptest b/meta-python/recipes-devtools/python/python3-cachetools/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-cachetools/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-cachetools/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_5.3.2.bb b/meta-python/recipes-devtools/python/python3-cachetools_5.3.2.bb
index 5946c267aa..22060ef049 100644
--- a/meta-python/recipes-devtools/python/python3-cachetools_5.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-cachetools_5.3.2.bb
@@ -15,11 +15,12 @@ SRC_URI += " \
"
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-math \
+ python3-math \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {