aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Leitner <dev@g0hl1n.net>2024-02-05 13:58:28 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-10 10:39:58 -0800
commit704b091001c7abc282ff6a29344357f26e321988 (patch)
treeb8b37115f3c969a9c9edcab4b3134e3ac381c173
parent057781a7331685e3d9b4a93be05a1d47f5d0ac27 (diff)
downloadmeta-openembedded-contrib-704b091001c7abc282ff6a29344357f26e321988.tar.gz
python3-httpcore: add recipe for v1.0.2
A minimal low-level HTTP client. This recipe is currently provided without trio support, as the author has no use for it and it would require to add a new python3-trio recipe. This recipe uses pypi as source: https://pypi.org/project/httpcore Signed-off-by: Richard Leitner <dev@g0hl1n.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb b/meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb
new file mode 100644
index 0000000000..3bfe5ed4ae
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A minimal low-level HTTP client."
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1c1f23b073da202e1f4f9e426490210c"
+
+inherit pypi python_hatchling
+
+SRC_URI[sha256sum] = "9fc092e4799b26174648e54b74ed5f683132a464e95643b226e00c2ed2fa6535"
+
+DEPENDS += "\
+ python3-hatch-fancy-pypi-readme-native \
+"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[http2] = ",,,python3-h2"
+PACKAGECONFIG[socks] = ",,,python3-socksio"
+PACKAGECONFIG[asyncio] = ",,,python3-anyio"
+# Don't provide "trio" PACKAGECONFIG as nothing provides "python3-trio" currently.
+# If somebody needs this please feel free to add python3-trio and enable the
+# packageconfig below:
+#PACKAGECONFIG[trio] = ",,,python3-trio"
+
+RDEPENDS:${PN} += "\
+ python3-certifi \
+ python3-h11 \
+"