aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-06 23:13:48 -0800
committerArmin Kuster <akuster808@gmail.com>2017-08-04 20:43:54 -0700
commit2a63f028e5f62a378eaa3a3a469099ef2ee001a6 (patch)
treecaa0b069f95fc1b2e6275fb646a3a5625dda7a26
parent0730f3f420c8b36a77d1c3aa0768ea64d9559e33 (diff)
downloadmeta-openembedded-contrib-2a63f028e5f62a378eaa3a3a469099ef2ee001a6.tar.gz
iptraf: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit ff5d50b43f9729fce33360fa0e9e7ff6a51ac7cf) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/iptraf/iptraf/format_string.patch31
-rw-r--r--meta-oe/recipes-devtools/iptraf/iptraf/ldopts.patch35
-rw-r--r--meta-oe/recipes-devtools/iptraf/iptraf_3.0.0.bb7
3 files changed, 71 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/iptraf/iptraf/format_string.patch b/meta-oe/recipes-devtools/iptraf/iptraf/format_string.patch
new file mode 100644
index 0000000000..5f96f0f4c4
--- /dev/null
+++ b/meta-oe/recipes-devtools/iptraf/iptraf/format_string.patch
@@ -0,0 +1,31 @@
+Index: iptraf-3.0.0/src/othptab.c
+===================================================================
+--- iptraf-3.0.0.orig/src/othptab.c
++++ iptraf-3.0.0/src/othptab.c
+@@ -335,7 +335,7 @@ void printothpentry(struct othptable *ta
+ break;
+ }
+
+- sprintf(scratchpad, inet_ntoa(saddr));
++ sprintf(scratchpad, "%s", inet_ntoa(saddr));
+ strcat(msgstring, scratchpad);
+ wattrset(table->othpwin, ARPATTR);
+ break;
+@@ -354,7 +354,7 @@ void printothpentry(struct othptable *ta
+ break;
+ }
+
+- sprintf(scratchpad, rarp_mac_addr);
++ sprintf(scratchpad, "%s", rarp_mac_addr);
+ strcat(msgstring, scratchpad);
+ wattrset(table->othpwin, ARPATTR);
+ break;
+@@ -421,7 +421,7 @@ void printothpentry(struct othptable *ta
+ wattrset(table->othpwin, UNKNIPATTR);
+ protptr = getprotobynumber(entry->protocol);
+ if (protptr != NULL) {
+- sprintf(protname, protptr->p_aliases[0]);
++ sprintf(protname, "%s", protptr->p_aliases[0]);
+ } else {
+ sprintf(protname, "IP protocol");
+ unknown = 1;
diff --git a/meta-oe/recipes-devtools/iptraf/iptraf/ldopts.patch b/meta-oe/recipes-devtools/iptraf/iptraf/ldopts.patch
new file mode 100644
index 0000000000..c84a0a0adf
--- /dev/null
+++ b/meta-oe/recipes-devtools/iptraf/iptraf/ldopts.patch
@@ -0,0 +1,35 @@
+Index: iptraf-3.0.0/src/Makefile
+===================================================================
+--- iptraf-3.0.0.orig/src/Makefile
++++ iptraf-3.0.0/src/Makefile
+@@ -5,7 +5,7 @@
+ #
+ # Architecture determination string borrowed from the kernel makefile.
+ #
+-ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \
++ARCH ?= $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \
+ -e s/arm.*/arm/ -e s/sa110/arm/)
+ PLATFORM = -DPLATFORM=\"$(shell uname -s)/$(ARCH)\"
+ VERNUMBER := $(shell cat version)
+@@ -17,7 +17,7 @@ VERSION = -DVERSION=\"$(VERNUMBER)\"
+ #
+ BINDIR = ../../iptraf-$(VERNUMBER).bin.$(ARCH)
+
+-CC = gcc
++CC = $(CC)
+ LIBS = -L../support -ltextbox -lpanel -lncurses # in this order!
+
+ # comment this one out to omit debug code when done.
+@@ -31,10 +31,10 @@ PROF = #-pg
+ # options to be passed to the compiler. I don't believe they need to be
+ # modified (except for -m486 on non-Intel x86 platforms).
+
+-CFLAGS = -Wall #-O2 #-m486
++CFLAGS ?= -Wall #-O2 #-m486
+ DIRS = -DWORKDIR=\"$(WORKDIR)\" \
+ -DLOGDIR=\"$(LOGDIR)\" -DEXECDIR=\"$(TARGET)\"
+-LDOPTS = #-static
++LDOPTS ?= #-static
+
+ # you may want to change this to point to your ncurses include directory
+ # if the ncurses include files are not in the default location.
diff --git a/meta-oe/recipes-devtools/iptraf/iptraf_3.0.0.bb b/meta-oe/recipes-devtools/iptraf/iptraf_3.0.0.bb
index e7a406fc5a..abfab02e04 100644
--- a/meta-oe/recipes-devtools/iptraf/iptraf_3.0.0.bb
+++ b/meta-oe/recipes-devtools/iptraf/iptraf_3.0.0.bb
@@ -12,12 +12,15 @@ DEPENDS = "ncurses"
SRC_URI = " \
ftp://iptraf.seul.org/pub/iptraf/iptraf-3.0.0.tar.gz \
- file://0001-src-Fix-error-in-cross-compile.patch"
+ file://0001-src-Fix-error-in-cross-compile.patch \
+ file://format_string.patch \
+ file://ldopts.patch \
+"
SRC_URI[md5sum] = "377371c28ee3c21a76f7024920649ea8"
SRC_URI[sha256sum] = "9ee433d95573d612539da4b452e6cdcbca6ab6674a88bfbf6eaf12d4902b5163"
RDEPENDS_${PN} = "ncurses"
-EXTRA_OEMAKE = "-e MAKEFLAGS="
+EXTRA_OEMAKE = "-e MAKEFLAGS= LDOPTS='${LDFLAGS}' ARCH='${TARGET_ARCH}'"
do_compile() {
oe_runmake -C src all