aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-02-11 10:15:54 -0500
committerArmin Kuster <akuster808@gmail.com>2018-02-11 13:41:13 -0800
commitce826443654451972f49516023038829b20dd13d (patch)
treeb68ed078d4bbaa465db95c4a0782af3c06d68dfb
parent011c93e6b599b7340bfd8dd8f273a901024b7c5a (diff)
downloadmeta-openembedded-contrib-ce826443654451972f49516023038829b20dd13d.tar.gz
python-pycryptodome: update to version 3.4.11
Update RDEPENDS to work on minimal python distribution Create a test package for unit tests Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pycryptodome.inc20
-rw-r--r--meta-python/recipes-devtools/python/python-pycryptodome_3.4.11.bb (renamed from meta-python/recipes-devtools/python/python-pycryptodome_3.4.8.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-pycryptodome_3.4.11.bb (renamed from meta-python/recipes-devtools/python/python3-pycryptodome_3.4.8.bb)0
3 files changed, 18 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycryptodome.inc b/meta-python/recipes-devtools/python/python-pycryptodome.inc
index 1efe1eb27b..c4969f9667 100644
--- a/meta-python/recipes-devtools/python/python-pycryptodome.inc
+++ b/meta-python/recipes-devtools/python/python-pycryptodome.inc
@@ -5,9 +5,25 @@ HOMEPAGE = "http://www.pycryptodome.org"
LICENSE = "PD & BSD-2-Clause"
LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=775fe77831c03bf82f35abc0e230d4c1"
-SRC_URI[md5sum] = "030c40da6377bbc82deef8e884fa22cd"
-SRC_URI[sha256sum] = "ede7f1f44b0895feb8ddbf882d1a7eb504deb3fa34fcc4860d6065c25cbdf175"
+SRC_URI[md5sum] = "a2587b6381b0ef4eb960cea1e7507d04"
+SRC_URI[sha256sum] = "c5dd29e9f1b733e74311bf95d0e544e91bd1d14bc0366e8f443562d8d9920b7d"
inherit pypi
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-math \
+"
+
+RDEPENDS_${PN}-tests += " \
+ ${PYTHON_PN}-unittest \
+"
+
+PACKAGES =+ "${PN}-tests"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/Crypto/SelfTest/ \
+ ${PYTHON_SITEPACKAGES_DIR}/Crypto/SelfTest/__pycache__/ \
+"
+
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pycryptodome_3.4.8.bb b/meta-python/recipes-devtools/python/python-pycryptodome_3.4.11.bb
index c7701eb9f9..c7701eb9f9 100644
--- a/meta-python/recipes-devtools/python/python-pycryptodome_3.4.8.bb
+++ b/meta-python/recipes-devtools/python/python-pycryptodome_3.4.11.bb
diff --git a/meta-python/recipes-devtools/python/python3-pycryptodome_3.4.8.bb b/meta-python/recipes-devtools/python/python3-pycryptodome_3.4.11.bb
index 0c062dddf8..0c062dddf8 100644
--- a/meta-python/recipes-devtools/python/python3-pycryptodome_3.4.8.bb
+++ b/meta-python/recipes-devtools/python/python3-pycryptodome_3.4.11.bb