aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Meresiński <tomasz.meresinski@comarch.pl>2018-02-07 17:43:52 +0100
committerArmin Kuster <akuster808@gmail.com>2018-02-11 13:38:04 -0800
commit9cfaa3a7afaa9abea10c25826c3b94f143bf1bed (patch)
tree79f586afa9ef5e02f89b7d4b6dc393f16fb3cfe7
parent15e12b0d273d8e7a778565e144609646ea25f29c (diff)
downloadmeta-openembedded-contrib-9cfaa3a7afaa9abea10c25826c3b94f143bf1bed.tar.gz
python3-twisted: remove python3-twisted-src
In python2 .py files are not necessary when importing a module. In python3 it's impossible to import without them. Removing python3-twisted-src makes .py files appear in packages again. Signed-off-by: Tomasz Meresiński<tomasz.meresinski@comarch.pl> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb b/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
index dfb9d4a4cc..6bd8c52eb0 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
@@ -1,6 +1,8 @@
inherit pypi setuptools3
require python-twisted.inc
+PACKAGES_remove = "${PN}-src"
+
FILES_${PN}-core_append += " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \
${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \