aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-05-11 19:21:43 +0000
committerKhem Raj <raj.khem@gmail.com>2018-05-18 12:30:56 -0700
commit921ad07591df287795cb3f42410117e86ac37e66 (patch)
tree201c41ef9689b6c4ce59011d8bf45b94732a5b93
parent2fbe1e0b02c1d247cf09667e702e6730e5c9fbd8 (diff)
downloadmeta-openembedded-contrib-921ad07591df287795cb3f42410117e86ac37e66.tar.gz
celt051: make ogg support optional
* drop PR * add +git to PV * and support for native and nativesdk needed for spice * the old PACKAGECONFIG didn't work, because both options aren't recognized as shown by do_configure warning: configure: WARNING: unrecognized options: --without-ogg, --disable-oggtest * XIPH_PATH_OGG macro is provided by libogg so we cannot call it without the libogg dependency, so replace it with explicit --enable-tools Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/celt051/celt051/0001-configure.ac-make-tools-support-optional.patch39
-rw-r--r--meta-networking/recipes-support/celt051/celt051_git.bb16
2 files changed, 48 insertions, 7 deletions
diff --git a/meta-networking/recipes-support/celt051/celt051/0001-configure.ac-make-tools-support-optional.patch b/meta-networking/recipes-support/celt051/celt051/0001-configure.ac-make-tools-support-optional.patch
new file mode 100644
index 0000000000..b0809ee947
--- /dev/null
+++ b/meta-networking/recipes-support/celt051/celt051/0001-configure.ac-make-tools-support-optional.patch
@@ -0,0 +1,39 @@
+From 86df4200c9c33d999df0e8cc3c9771f17a297ec4 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Wed, 13 Sep 2017 15:01:54 +0200
+Subject: [PATCH] configure.ac: make tools support optional
+
+* add --enable-tools option
+* XIPH_PATH_OGG macro is provided by libogg so we cannot call
+ it without the libogg dependency
+
+Upstream-Status: Pending
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ configure.ac | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index d4b1a3f..7d6b2dc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -68,8 +68,14 @@ AC_MSG_RESULT($has_alloca)
+
+ AC_CHECK_HEADERS(sys/soundcard.h sys/audioio.h)
+
+-XIPH_PATH_OGG([tools="tools"], [tools=""])
++AC_ARG_ENABLE(tools, [ --enable-tools Compile ogg tools],
++[if test "$enableval" = yes; then
++ [tools="tools"]
++else
++ [tools=""]
++fi],
+ AC_SUBST(tools)
++)
+
+ AC_CHECK_LIB(m, sin)
+
+--
+2.14.1
+
diff --git a/meta-networking/recipes-support/celt051/celt051_git.bb b/meta-networking/recipes-support/celt051/celt051_git.bb
index ee3882148e..850704f5af 100644
--- a/meta-networking/recipes-support/celt051/celt051_git.bb
+++ b/meta-networking/recipes-support/celt051/celt051_git.bb
@@ -12,19 +12,21 @@ like Speex, GSM, or G.729."
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=375f60ab360d17f0172737036ff155b2"
-PV = "0.5.1.3"
-PR = "r0"
+PV = "0.5.1.3+git${SRCPV}"
SRCREV = "5555aae843f57241d005e330b9cb65602d56db0f"
-SRC_URI = "git://git.xiph.org/celt.git;branch=compat-v0.5.1;protocol=https"
+SRC_URI = "git://git.xiph.org/celt.git;branch=compat-v0.5.1;protocol=https \
+ file://0001-configure.ac-make-tools-support-optional.patch \
+"
S = "${WORKDIR}/git"
-DEPENDS += "libogg"
-
inherit pkgconfig autotools-brokensep
-PACKAGECONFIG = ""
+PACKAGECONFIG_class-native = ""
+PACKAGECONFIG ??= ""
+
+PACKAGECONFIG[ogg] = "--enable-tools,--disable-tools,libogg,"
-PACKAGECONFIG[ogg] = "--with-ogg --enable-oggtest,--without-ogg --disable-oggtest,,"
+BBCLASSEXTEND = "native nativesdk"