aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-01-23 14:15:03 -0800
committerArmin Kuster <akuster808@gmail.com>2018-02-11 11:46:48 -0800
commit734ae12ed8080abff5641c57e3a8617be0ae2968 (patch)
tree366aa781353ebfbfa9bc50e4b78416801db3cedb
parent196186de630c93529433d50292fd4e44e14af3f9 (diff)
downloadmeta-openembedded-contrib-734ae12ed8080abff5641c57e3a8617be0ae2968.tar.gz
cpuid: add recipe for v20170122
cpuid dumps detailed information about the CPU(s) gathered from the CPUID instruction, and also determines the exact model of CPU(s). It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, UMC, NexGen, Rise, and SiS CPUs. http://www.etallen.com/cpuid.html Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb b/meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb
new file mode 100644
index 0000000000..7a70f75763
--- /dev/null
+++ b/meta-oe/recipes-devtools/cpuid/cpuid_20170122.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)"
+DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \
+from the CPUID instruction, and also determines the exact model of CPU(s). \
+It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \
+UMC, NexGen, Rise, and SiS CPUs"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz"
+SRC_URI[md5sum] = "1c46a6662626c5a6eaca626f23a5a7d7"
+SRC_URI[sha256sum] = "667612aae6704341dd10844e97c84c5c5c8700817a5937a3c293b55013bc4865"
+
+COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
+
+# The install rule from the Makefile has hardcoded paths, so we duplicate
+# the actions to accommodate different paths.
+do_install () {
+ install -d -m755 ${D}/${bindir}
+ install -m755 ${B}/cpuid ${D}/${bindir}/cpuid
+ install -d -m755 ${D}/${mandir}
+ install -m444 ${B}/cpuid.man.gz ${D}/${mandir}
+}