aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-17 10:13:50 -0800
committerArmin Kuster <akuster808@gmail.com>2020-01-05 14:43:51 -0800
commit90c2a266f98fef55f73b3b89d8915b022fbf1a8a (patch)
treedf61349b47b5776861148281a953417bfd896846
parent22bec3b2606347b895adde3c154280a87e1f3f87 (diff)
downloadmeta-openembedded-contrib-90c2a266f98fef55f73b3b89d8915b022fbf1a8a.tar.gz
libqb: Add --enable-nosection-fallback with mips64/clang
Same issue happens with clang/mips64 so extend the gold fix to cover for this case Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit dd69fafd7f2c51fb69df66dbeae7f5a4b092580c) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libqb/libqb_1.0.5.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/libqb/libqb_1.0.5.bb b/meta-oe/recipes-extended/libqb/libqb_1.0.5.bb
index b205186e0b..82503a168b 100644
--- a/meta-oe/recipes-extended/libqb/libqb_1.0.5.bb
+++ b/meta-oe/recipes-extended/libqb/libqb_1.0.5.bb
@@ -22,9 +22,13 @@ S = "${WORKDIR}/git"
# WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: error: conftest.ld: SECTIONS seen after other input files; try -T/--script
# WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: internal error in write_sections, at ../../gold/reloc.cc:791
# collect2: error: ld returned 1 exit status
-EXTRA_OECONF_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' --enable-nosection-fallback', '', d)}"
+NOSECTION_FALLBACK = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '--enable-nosection-fallback', '', d)}"
+NOSECTION_FALLBACK_toolchain-clang_mips64 = "--enable-nosection-fallback"
+
+EXTRA_OECONF += "${NOSECTION_FALLBACK}"
CFLAGS += "-pthread -D_REENTRANT"
+
do_configure_prepend() {
( cd ${S}
${S}/autogen.sh )