aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-10-10 17:47:38 -0700
committerKhem Raj <raj.khem@gmail.com>2019-10-10 21:58:10 -0700
commit0272da33e7abf5c76c2a010913e8618cb1e9d6a7 (patch)
tree8b30515beb8f276152a6440c456dda6f0509c22a
parent8887455a442aa5377ebef9d84d0c61884540154a (diff)
downloadmeta-openembedded-contrib-0272da33e7abf5c76c2a010913e8618cb1e9d6a7.tar.gz
jsonrpc: Disable coverage in default build
Building with intrumentation is only useful during development or optimization phases, in production, this will just make it slow and in some cases not work where file system might be readonly. If its needed then enable the packageconfig via a bbappend Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.2.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.2.0.bb b/meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.2.0.bb
index b23775708a..dbf44d796f 100644
--- a/meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.2.0.bb
+++ b/meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.2.0.bb
@@ -14,6 +14,9 @@ SRCREV = "4ed5b00dcc409405a19e6d8c6478f703153430e1"
S = "${WORKDIR}/git"
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[coverage] = "-DWITH_COVERAGE=YES,-DWITH_COVERAGE=NO,,"
+
inherit cmake
EXTRA_OECMAKE += "-DCOMPILE_TESTS=NO -DCOMPILE_STUBGEN=NO -DCOMPILE_EXAMPLES=NO \