aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-12-05 14:37:46 +0000
committerArmin Kuster <akuster808@gmail.com>2019-02-04 21:33:18 -0800
commite471c9d0103af97987570210e40344bc536e2792 (patch)
tree69b48ba71b0bc85c9bbf5d3b4b651d22951b31c2
parenta9957a2c047fc963cba4c65eceba2107caee3484 (diff)
downloadmeta-openembedded-contrib-e471c9d0103af97987570210e40344bc536e2792.tar.gz
open-vm-tools: fix indentation and drop FILES_${PN}-dbg
* don't mix tabs and spaces for indentation, removes new warning: meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb: python should use 4 spaces indentation, but found tabs in open-vm-tools_10.3.0.bb, line 107 * remove FILES_${PN}-dbg variable, all .debug directories are packaged automatically in ${PN}-dbg for long time (at least since 2.1 Krogoth) since this oe-core commit: commit da5ec06814e105451cca11cce76b5c5231110524 Author: Richard Purdie <richard.purdie@linuxfoundation.org> Date: Tue Dec 15 15:38:54 2015 +0000 package: Add auto package splitting of .debug files Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb47
1 files changed, 21 insertions, 26 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
index 478d762cfb..2d7486da34 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
@@ -22,22 +22,22 @@ LICENSE_modules/linux = "GPL-2.0"
LICENSE_modules/solaris = "CDDL-1.0"
SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
- file://tools.conf \
- file://vmtoolsd.service \
- file://vmtoolsd.init \
- file://0001-configure.ac-don-t-use-dnet-config.patch \
- file://0002-add-include-sys-sysmacros.h.patch \
- file://0005-Use-configure-test-for-struct-timespec.patch \
- file://0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch \
- file://0007-Use-configure-to-test-for-feature-instead-of-platfor.patch \
- file://0011-Use-configure-test-for-sys-stat.h-include.patch \
- file://fix-subdir-objects-configure-error.patch \
- file://0001-include-poll.h-instead-of-sys-poll.h.patch \
- file://0002-Rename-poll.h-to-vm_poll.h.patch \
- file://0003-use-posix-strerror_r-unless-on-gnu-libc-system.patch \
- file://0004-Use-uintmax_t-for-handling-rlim_t.patch \
- file://0001-Use-off64_t-instead-of-__off64_t.patch \
- "
+ file://tools.conf \
+ file://vmtoolsd.service \
+ file://vmtoolsd.init \
+ file://0001-configure.ac-don-t-use-dnet-config.patch \
+ file://0002-add-include-sys-sysmacros.h.patch \
+ file://0005-Use-configure-test-for-struct-timespec.patch \
+ file://0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch \
+ file://0007-Use-configure-to-test-for-feature-instead-of-platfor.patch \
+ file://0011-Use-configure-test-for-sys-stat.h-include.patch \
+ file://fix-subdir-objects-configure-error.patch \
+ file://0001-include-poll.h-instead-of-sys-poll.h.patch \
+ file://0002-Rename-poll.h-to-vm_poll.h.patch \
+ file://0003-use-posix-strerror_r-unless-on-gnu-libc-system.patch \
+ file://0004-Use-uintmax_t-for-handling-rlim_t.patch \
+ file://0001-Use-off64_t-instead-of-__off64_t.patch \
+"
SRCREV = "2147df6aabe639fc5ff423ed791a8e7f02bf8d0a"
S = "${WORKDIR}/git/open-vm-tools"
@@ -52,9 +52,9 @@ inherit autotools pkgconfig systemd update-rc.d
SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \
- --disable-tests --without-gtkmm --without-xerces --without-pam \
- --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \
- --without-root-privileges --without-kernel-modules"
+ --disable-tests --without-gtkmm --without-xerces --without-pam \
+ --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \
+ --without-root-privileges --without-kernel-modules"
NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
@@ -68,13 +68,9 @@ FILES_${PN} += "\
${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \
${libdir}/open-vm-tools/plugins/common/lib*.so \
${sysconfdir}/vmware-tools/tools.conf \
- "
+"
FILES_${PN}-locale += "${datadir}/open-vm-tools/messages"
FILES_${PN}-dev += "${libdir}/open-vm-tools/plugins/common/lib*.la"
-FILES_${PN}-dbg += "\
- ${libdir}/open-vm-tools/plugins/common/.debug \
- ${libdir}/open-vm-tools/plugins/vmsvc/.debug \
- "
CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf"
@@ -104,7 +100,6 @@ INITSCRIPT_PARAMS_${PN} = "start 90 2 3 4 5 . stop 60 0 1 6 ."
python() {
if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \
- 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
+ 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
raise bb.parse.SkipRecipe('Requires meta-networking and meta-filesystems to be present.')
}
-