aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-03-07 16:11:11 -0500
committerArmin Kuster <akuster808@gmail.com>2019-03-24 18:44:58 -0700
commit6cc951d6578db9567a474f7eb577b71ecdbe3ec9 (patch)
tree83cbf4def283f385dcb31e077c682efa1892acb2
parent6ef9657068492d4644079c88f2adee9c3cac9543 (diff)
downloadmeta-openembedded-contrib-6cc951d6578db9567a474f7eb577b71ecdbe3ec9.tar.gz
mosquitto: fix build in systemd environments
The mosquitto systemd service file instructs systemd to wait for mosquitto to notify systemd that mosquitto has started correctly. This isn't working as mosquitto is not *compiled* with systemd support enabled. As such, systemd restarts mosquitto every few seconds. For reference, this was introduced in commit a483d344d9fb ("mosquitto: Make enabling systemd also enable build dep on systemd") Because we build mosquitto using the provided Makefile infrastructure, the solution is to add PACKAGECONFIG_CONFARGS to EXTRA_OEMAKE, so that the required make flags are added to the make command line. Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Damien Riegel <damien.riegel@gmail.com> [Damien Riegel: backport from master] Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.1.bb b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.1.bb
index b4adfdada9..52252787d1 100644
--- a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.1.bb
+++ b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.1.bb
@@ -38,6 +38,7 @@ EXTRA_OEMAKE = " \
${@bb.utils.contains('PACKAGECONFIG', 'ssl', 'WITH_TLS=yes WITH_TLS_PSK=yes', 'WITH_TLS=no WITH_TLS_PSK=no', d)} \
${@bb.utils.contains('PACKAGECONFIG', 'uuid', 'WITH_UUID=yes', 'WITH_UUID=no', d)} \
${@bb.utils.contains('PACKAGECONFIG', 'websockets', 'WITH_WEBSOCKETS=yes', 'WITH_WEBSOCKETS=no', d)} \
+ ${PACKAGECONFIG_CONFARGS} \
STRIP=/bin/true \
WITH_DOCS=no \
"