aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-01-29 21:17:23 -0800
committerArmin Kuster <akuster808@gmail.com>2019-02-04 22:01:26 -0800
commit0e8912b5723b5b2de32977ab0c736c32bcc94b0c (patch)
tree13a57ea3a33da14dc91752bcbae62fd04dbca285
parent2ae6aaf9e734022b40d23f12099b1cb9c4934ca2 (diff)
downloadmeta-openembedded-contrib-0e8912b5723b5b2de32977ab0c736c32bcc94b0c.tar.gz
mozjs: Fix symbol visibility with clang/libc++
Signed-off-by: Khem Raj <raj.khem@gmail.com> [fixup for thud context] Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs/JS_PUBLIC_API.patch37
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs/JS_PUBLIC_API.patch b/meta-oe/recipes-extended/mozjs/mozjs/JS_PUBLIC_API.patch
new file mode 100644
index 0000000000..6c87ff2a4c
--- /dev/null
+++ b/meta-oe/recipes-extended/mozjs/mozjs/JS_PUBLIC_API.patch
@@ -0,0 +1,37 @@
+Patch from https://bugzilla.mozilla.org/show_bug.cgi?id=1426865
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Submitted [https://bugzilla.mozilla.org/show_bug.cgi?id=1426865]
+--- a/js/public/TypeDecls.h
++++ b/js/public/TypeDecls.h
+@@ -21,22 +21,23 @@
+ #include <stdint.h>
+
+ #include "js-config.h"
++#include "jstypes.h"
+
+ struct JSContext;
+-class JSFunction;
++class JS_PUBLIC_API(JSFunction);
+ class JSObject;
+-class JSScript;
+-class JSString;
+-class JSAddonId;
++class JS_PUBLIC_API(JSScript);
++class JS_PUBLIC_API(JSString);
++class JS_PUBLIC_API(JSAddonId);
+
+-struct jsid;
++struct JS_PUBLIC_API(jsid);
+
+ namespace JS {
+
+ typedef unsigned char Latin1Char;
+
+-class Symbol;
+-class Value;
++class JS_PUBLIC_API(Symbol);
++class JS_PUBLIC_API(Value);
+ template <typename T> class Handle;
+ template <typename T> class MutableHandle;
+ template <typename T> class Rooted;
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb b/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb
index 440a25b74e..7c8a7aee10 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb
@@ -14,6 +14,7 @@ SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/main/m/mozjs52/mozjs52_52.9.1.o
file://disable-mozglue-in-stand-alone-builds.patch \
file://add-riscv-support.patch \
file://0001-mozjs-fix-coredump-caused-by-getenv.patch \
+ file://JS_PUBLIC_API.patch \
"
SRC_URI_append_libc-musl = " \
file://0006-support-musl.patch \