aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-10-24 16:22:34 +0800
committerArmin Kuster <akuster808@gmail.com>2018-02-01 07:32:03 -0800
commit9afe8a43a4991d5b4a5d08c9e20eacd0a997af53 (patch)
treef3d88ff73a2f02506dc9b4f7f6763931fb7527b2
parentf83f2907723761eb0623ac04dee77063cf4aff7d (diff)
downloadmeta-openembedded-contrib-9afe8a43a4991d5b4a5d08c9e20eacd0a997af53.tar.gz
samba: add missing RDEPENDS
* samba-tool requires the python modules from samba-python or it fails with: Traceback (most recent call last): File "/usr/bin/samba-tool", line 33, in <module> from samba.netcmd.main import cmd_sambatool ImportError: No module named samba.netcmd.main * Provisioning with samba-tool requires samba-dsdb-modules or it fails with: Setting up secrets.ldb ldb: unable to stat module /usr/lib64/samba/ldb : No such file or directory WARNING: Module [samba_secrets] not found - do you need to set LDB_MODULES_PATH? Unable to load modules for /var/lib/samba/private/secrets.ldb: (null) ERROR(ldb): uncaught exception - None * samba-python requires pytalloc and python-tdb or it fails with: TypeError: pytalloc: unable to get talloc.BaseObject type ERROR(<type 'exceptions.ImportError'>): uncaught exception - No module named tdb Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> (cherry picked from commit 9245c2a7ec30ba5df6826acd91d7a76d7f51d017) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.6.7.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.6.7.bb b/meta-networking/recipes-connectivity/samba/samba_4.6.7.bb
index 59d7425c8d..2b227c95d1 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.6.7.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.6.7.bb
@@ -186,7 +186,8 @@ python samba_populate_packages() {
PACKAGESPLITFUNCS_prepend = "samba_populate_packages "
-RDEPENDS_${PN} += "${PN}-base"
+RDEPENDS_${PN} += "${PN}-base ${PN}-python ${PN}-dsdb-modules"
+RDEPENDS_${PN}-python += "pytalloc python-tdb"
FILES_${PN}-base = "${sbindir}/nmbd \
${sbindir}/smbd \