aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2017-09-27 12:15:27 -0700
committerArmin Kuster <akuster808@gmail.com>2017-11-15 15:46:58 -0800
commit5a70fffe603c2d2947c8499b8691cb3cda92888e (patch)
tree98bbde73f4a396ecb7bf52bcf657620ff5bdd6ec
parent010e7ae6aabd94f566b8df5f52623efb3f6dac8f (diff)
downloadmeta-openembedded-contrib-5a70fffe603c2d2947c8499b8691cb3cda92888e.tar.gz
luajit: mips and mipsel are 32bit targets too
When cross compiling, the word size of the compiler set via HOST_CC must match the word size of the target. That's achieved by appending "-m32" to BUILD_CC_ARCH if the target word size is known to be 32bits. Unfortunately the current list of over-rides (powerpc, x86 and arm) does not cover all cases. Add mips and mipsel to the list too (which is still not enough to cover all targets or corner cases such as x32, but better than before). Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 18771a9c9946c04dcd3ec89559018c8bbb15201c) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb b/meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb
index 964dc1d590..2049846345 100644
--- a/meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb
+++ b/meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb
@@ -24,6 +24,8 @@ BBCLASSEXTEND = "native"
BUILD_CC_ARCH_append_powerpc = ' -m32'
BUILD_CC_ARCH_append_x86 = ' -m32'
BUILD_CC_ARCH_append_arm = ' -m32'
+BUILD_CC_ARCH_append_mips = ' -m32'
+BUILD_CC_ARCH_append_mipsel = ' -m32'
# The lua makefiles expect the TARGET_SYS to be from uname -s
# Values: Windows, Linux, Darwin, iOS, SunOS, PS3, GNU/kFreeBSD