aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2022-07-19 22:01:46 -0700
committerArmin Kuster <akuster808@gmail.com>2022-07-21 07:17:33 -0700
commitf1d7666dceffc807fd5eabf8f18ba18826aff0ea (patch)
treeca077d2a5d1c9aff17a897d1d76808be32586114
parent4f0231595fb51ea2dd7bc0626bca3711040f19b4 (diff)
downloadmeta-openembedded-contrib-f1d7666dceffc807fd5eabf8f18ba18826aff0ea.tar.gz
catfish: fix buildpaths issue
Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit c2fb0bd1ebe04f91e97913e1e15405af0e127078) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-xfce/recipes-apps/catfish/catfish_4.16.3.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/catfish/catfish_4.16.3.bb b/meta-xfce/recipes-apps/catfish/catfish_4.16.3.bb
index 98cd251d2d..8fe879b816 100644
--- a/meta-xfce/recipes-apps/catfish/catfish_4.16.3.bb
+++ b/meta-xfce/recipes-apps/catfish/catfish_4.16.3.bb
@@ -12,3 +12,12 @@ SRC_URI[sha256sum] = "e9a99a62d10981391508dd43f3cbfa2d50a69bd6b7d1eeef7d30ba4c67
FILES:${PN} += "${datadir}/metainfo"
RDEPENDS:${PN} += "python3-pygobject python3-dbus"
+
+do_install:append() {
+ #
+ # Until catfish upstream figures out a way to overcome this buildpath issue, we need to do such adjustments here.
+ #
+ sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' ${D}${datadir}/applications/org.xfce.Catfish.desktop
+ sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/catfish_lib/catfishconfig.py
+ rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/catfish_lib/__pycache__/catfishconfig.*.pyc
+}