aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-03-05 09:48:54 -0600
committerArmin Kuster <akuster808@gmail.com>2023-03-13 08:58:37 -0400
commitacd692b775eeb913e83f1d2b96440277e78a7659 (patch)
treebcc91f1c9316fb99e80096b4a60b118f0d66a94e
parent9d4bbb9b32632397af0dc388b456565efd1517ed (diff)
downloadmeta-openembedded-contrib-acd692b775eeb913e83f1d2b96440277e78a7659.tar.gz
nlohmann-json: Allow empty main package for SDK
The header-only package cannot be included in the SDK without marking the main package with ALLOW_EMPTY. Fixes rootfs problem: ``` The following packages have unmet dependencies: imx-gpu-sdk : Depends: nlohmann-json but it is not installable E: Unable to correct problems, you have held broken packages. ``` Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit f9c9e7a448b9d9f7d54bbf09970223db467eedb2) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.5.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.5.bb b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.5.bb
index 0cf6fd36bc..4fa2aacdfc 100644
--- a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.5.bb
+++ b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.5.bb
@@ -18,7 +18,7 @@ inherit cmake
EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
# nlohmann-json is a header only C++ library, so the main package will be empty.
-
+ALLOW_EMPTY:${PN} = "1"
RDEPENDS:${PN}-dev = ""
BBCLASSEXTEND = "native nativesdk"