aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-04-12 07:14:20 +0200
committerArmin Kuster <akuster808@gmail.com>2023-04-13 08:26:26 -0400
commit6c555719121c6fdbc590598186969e51de8fb5ae (patch)
treef2d6b2516558d08348f549cbefef8c953804fc9e
parente5f27c78d5c9d42032def8ad271d9e204405c85c (diff)
downloadmeta-openembedded-contrib-6c555719121c6fdbc590598186969e51de8fb5ae.tar.gz
zsh: fix installed-vs-shipped with multilib
* fixes: lib32-zsh-5.8: lib32-zsh: Files/directories were installed but not shipped in any package: /usr/share/lib32-zsh /usr/share/lib32-zsh/5.8 /usr/share/lib32-zsh/site-functions /usr/share/lib32-zsh/5.8/functions /usr/share/lib32-zsh/5.8/functions/_selinux_users ... 1000+ lines ... /usr/share/lib32-zsh/5.8/functions/VCS_INFO_bydir_detect Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. lib32-zsh: 1116 installed and not shipped files. [installed-vs-shipped] * they will clash if someone is trying to install both zsh and lib32-zsh, but it's not very likely as nobody sane was building lib32-zsh with 1000+ line warning regularly Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-shells/zsh/zsh_5.8.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-shells/zsh/zsh_5.8.bb b/meta-oe/recipes-shells/zsh/zsh_5.8.bb
index b023e8d297..7602ff9f64 100644
--- a/meta-oe/recipes-shells/zsh/zsh_5.8.bb
+++ b/meta-oe/recipes-shells/zsh/zsh_5.8.bb
@@ -22,8 +22,8 @@ inherit autotools-brokensep gettext update-alternatives manpages
EXTRA_OECONF = " \
--bindir=${base_bindir} \
--enable-etcdir=${sysconfdir} \
- --enable-fndir=${datadir}/${PN}/${PV}/functions \
- --enable-site-fndir=${datadir}/${PN}/site-functions \
+ --enable-fndir=${datadir}/${BPN}/${PV}/functions \
+ --enable-site-fndir=${datadir}/${BPN}/site-functions \
--with-term-lib='ncursesw ncurses' \
--with-tcsetpgrp \
--enable-cap \