aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-11-07 16:41:53 +0800
committerArmin Kuster <akuster808@gmail.com>2023-02-06 10:12:18 -0500
commit62f7f24a323ebe98436304140162f6eb33141f94 (patch)
tree9941b92b2d04bef01ca47f4d70874de241043120
parent6a5772d376633f4f8deca597860ffe0163060a99 (diff)
downloadmeta-openembedded-contrib-62f7f24a323ebe98436304140162f6eb33141f94.tar.gz
python3-pillow: upgrade 9.2.0 -> 9.3.0
Changelog: ========= Limit SAMPLESPERPIXEL to avoid runtime DOS #6700 [wiredfool] Initialize libtiff buffer when saving #6699 [radarhere] Inline fname2char to fix memory leak #6329 [nulano] Fix memory leaks related to text features #6330 [nulano] Use double quotes for version check on old CPython on Windows #6695 [hugovk] Remove backup implementation of Round for Windows platforms #6693 [cgohlke] Fixed set_variation_by_name offset #6445 [radarhere] Fix malloc in _imagingft.c:font_setvaraxes #6690 [cgohlke] Release Python GIL when converting images using matrix operations #6418 [hmaarrfk] Added ExifTags enums #6630 [radarhere] Do not modify previous frame when calculating delta in PNG #6683 [radarhere] Added support for reading BMP images with RLE4 compression #6674 [npjg, radarhere] Decode JPEG compressed BLP1 data in original mode #6678 [radarhere] Added GPS TIFF tag info #6661 [radarhere] Added conversion between RGB/RGBA/RGBX and LAB #6647 [radarhere] Do not attempt normalization if mode is already normal #6644 [radarhere] Fixed seeking to an L frame in a GIF #6576 [radarhere] Consider all frames when selecting mode for PNG save_all #6610 [radarhere] Don't reassign crc on ChunkStream close #6627 [wiredfool, radarhere] Raise a warning if NumPy failed to raise an error during conversion #6594 [radarhere] Show all frames in ImageShow #6611 [radarhere] Allow FLI palette chunk to not be first #6626 [radarhere] If first GIF frame has transparency for RGB_ALWAYS loading strategy, use RGBA mode #6592 [radarhere] Round box position to integer when pasting embedded color #6517 [radarhere, nulano] Removed EXIF prefix when saving WebP #6582 [radarhere] Pad IM palette to 768 bytes when saving #6579 [radarhere] Added DDS BC6H reading #6449 [ShadelessFox, REDxEYE, radarhere] Added support for opening WhiteIsZero 16-bit integer TIFF images #6642 [JayWiz, radarhere] Raise an error when allocating translucent color to RGB palette #6654 [jsbueno, radarhere] Added reading of TIFF child images #6569 [radarhere] Improved ImageOps palette handling #6596 [PososikTeam, radarhere] Defer parsing of palette into colors #6567 [radarhere] Apply transparency to P images in ImageTk.PhotoImage #6559 [radarhere] Use rounding in ImageOps contain() and pad() #6522 [bibinhashley, radarhere] Fixed GIF remapping to palette with duplicate entries #6548 [radarhere] Allow remap_palette() to return an image with less than 256 palette entries #6543 [radarhere] Corrected BMP and TGA palette size when saving #6500 [radarhere] Do not call load() before draft() in Image.thumbnail #6539 [radarhere] Copy palette when converting from P to PA #6497 [radarhere] Allow RGB and RGBA values for PA image putpixel #6504 [radarhere] Removed support for tkinter in PyPy before Python 3.6 #6551 [nulano] Do not use CCITTFaxDecode filter if libtiff is not available #6518 [radarhere] Fallback to not using mmap if buffer is not large enough #6510 [radarhere] Fixed writing bytes as ASCII tag #6493 [radarhere] Open 1 bit EPS in mode 1 #6499 [radarhere] Removed support for tkinter before Python 1.5.2 #6549 [radarhere] Allow default ImageDraw font to be set #6484 [radarhere, hugovk] Save 1 mode PDF using CCITTFaxDecode filter #6470 [radarhere] Added support for RGBA PSD images #6481 [radarhere] Parse orientation from XMP tag contents #6463 [bigcat88, radarhere] Added support for reading ATI1/ATI2 (BC4/BC5) DDS images #6457 [REDxEYE, radarhere] Do not clear GIF tile when checking number of frames #6455 [radarhere] Support saving multiple MPO frames #6444 [radarhere] Do not double quote Pillow version for setuptools >= 60 #6450 [radarhere] Added ABGR BMP mask mode #6436 [radarhere] Fixed PSDraw rectangle #6429 [radarhere] Raise ValueError if PNG sRGB chunk is truncated #6431 [radarhere] Handle missing Python executable in ImageShow on macOS #6416 [bryant1410, radarhere] Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 4e075c7dc81c4d2824094f9d3523cf16719be9a7) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_9.3.0.bb (renamed from meta-python/recipes-devtools/python/python3-pillow_9.2.0.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow_9.2.0.bb b/meta-python/recipes-devtools/python/python3-pillow_9.3.0.bb
index 454d61a48e..11f5451609 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_9.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_9.3.0.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "https://pillow.readthedocs.io"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ad081a0aede51e89f8da13333a8fb849"
-SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=9.2.x;protocol=https \
+SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \
file://0001-support-cross-compiling.patch \
file://0001-explicitly-set-compile-options.patch \
"
@@ -39,4 +39,4 @@ RPROVIDES:${PN} += "python3-imaging"
BBCLASSEXTEND = "native"
-SRCREV = "58acec3312fb8671c9d84829197e1c8150085589"
+SRCREV = "d594f4cb8dc47fb0c69ae58d9fff86faae4515bd"