aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormassimo toscanelli <massimo.toscanelli@leica-geosystems.com>2021-07-08 12:58:51 +0000
committerArmin Kuster <akuster808@gmail.com>2021-07-14 21:27:01 -0700
commit6a7ba8f7f210e04183fb64ab181520d817a34a11 (patch)
tree0576cf8e7cfbfc48aa4191b63aa1ac3598630f3d
parent82cca6d4edd3bb3a3d888f2647d43256b5f4691c (diff)
downloadmeta-openembedded-contrib-6a7ba8f7f210e04183fb64ab181520d817a34a11.tar.gz
sysbench: fix memory test
In sysbench version 0.4, the tmp variable used by the memory test to execute requests is optimized by the compiler. Caching mechanism reduces the direct accesses to the memory increasing the transfer speed. This leads to false timing estimations that considerably affect read and also random write operations. In sysbench version 1, this issue is fixed adding the volatile modifier to the tmp variable. This prevents compiler optimizations forcing a direct access to the memory. The final result is a realistic transfer speed measurement. Signed-off-by: massimo toscanelli <massimo.toscanelli@leica-geosystems.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 59cce5ad1603c2975684ae15b639e0e3cd688c40) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch40
-rw-r--r--meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb4
2 files changed, 43 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch b/meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch
new file mode 100644
index 0000000000..d628e81b56
--- /dev/null
+++ b/meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch
@@ -0,0 +1,40 @@
+From c1ebf893e32a0a77e820484d48a903523fef7c1b Mon Sep 17 00:00:00 2001
+From: Vasily Tarasov <tarasov@vasily.name>
+Date: Fri, 10 Jun 2016 14:33:48 -0400
+Subject: [PATCH] Adding volatile modifier to tmp variable in memory test
+
+Issue explanation:
+
+./sysbench/sysbench --test=memory --num-threads=16 \
+ --memory-block-size=268435456 \
+ --memory-total-size=137438953472 \
+ --memory-oper=read \
+ --memory-access-mode=seq \
+ --memory-scope=local run
+
+Without this commit the time to run the above command is 0.0004 seconds.
+With this commit the time is greater than 3 seconds. Essentially,
+without the volatile modifier, the compiler optimizes read access so
+that no real access happens.
+
+Upstream-Status: Backport [part of v1.0.0 https://github.com/akopytov/sysbench/commit/8753cb93be4c0b81a20b704ced91e7a422da52b1]
+
+(cherry picked from commit 8753cb93be4c0b81a20b704ced91e7a422da52b1)
+Signed-off-by: massimo toscanelli <massimo.toscanelli@leica-geosystems.com>
+---
+ sysbench/tests/memory/sb_memory.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/sysbench/tests/memory/sb_memory.c b/sysbench/tests/memory/sb_memory.c
+index 2e8998f..7d22bb9 100644
+--- a/sysbench/tests/memory/sb_memory.c
++++ b/sysbench/tests/memory/sb_memory.c
+@@ -244,7 +244,7 @@ sb_request_t memory_get_request(int tid)
+ int memory_execute_request(sb_request_t *sb_req, int thread_id)
+ {
+ sb_mem_request_t *mem_req = &sb_req->u.mem_request;
+- int tmp = 0;
++ volatile int tmp = 0;
+ int idx;
+ int *buf, *end;
+ log_msg_t msg;
diff --git a/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb b/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
index 708c71f4ff..d1725dddd6 100644
--- a/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
+++ b/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
@@ -8,7 +8,9 @@ inherit autotools
# The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from
# Launchpad until the next release is available from Github.
-SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz"
+SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz \
+ file://0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch \
+ "
SRC_URI[md5sum] = "3a6d54fdd3fe002328e4458206392b9d"
SRC_URI[sha256sum] = "83fa7464193e012c91254e595a89894d8e35b4a38324b52a5974777e3823ea9e"