aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2021-06-13 00:53:59 +0200
committerArmin Kuster <akuster808@gmail.com>2021-06-27 06:57:04 -0700
commit5195f02b0d1b1ac91c3f2e1cc69c8ec9bc2ca2e0 (patch)
treeb33b3e10ad77385503b92b9213520e74f3bcb90f
parent32b4237a2729f025f641f0d52bb0b1b4d93da255 (diff)
downloadmeta-openembedded-contrib-5195f02b0d1b1ac91c3f2e1cc69c8ec9bc2ca2e0.tar.gz
initramfs-debug-image: support cases where machines override IMAGE_FSTYPES
As done for initramfs-kexecboot-image we need to use python to get the desired value for IMAGE_FSTYPES. Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 93e139c998857048182ed4169f04cfe350eab013) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-initramfs/recipes-core/images/initramfs-debug-image.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-initramfs/recipes-core/images/initramfs-debug-image.bb b/meta-initramfs/recipes-core/images/initramfs-debug-image.bb
index c3dcd2b821..601056b7e5 100644
--- a/meta-initramfs/recipes-core/images/initramfs-debug-image.bb
+++ b/meta-initramfs/recipes-core/images/initramfs-debug-image.bb
@@ -11,7 +11,12 @@ IMAGE_FEATURES = ""
export IMAGE_BASENAME = "initramfs-debug-image"
IMAGE_LINGUAS = ""
-IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+# Some BSPs use IMAGE_FSTYPES_<machine override> which would override
+# an assignment to IMAGE_FSTYPES so we need anon python
+python () {
+ d.setVar("IMAGE_FSTYPES", d.getVar("INITRAMFS_FSTYPES"))
+}
+
inherit core-image
IMAGE_ROOTFS_SIZE = "8192"