aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2020-09-02 20:38:17 -0700
committerArmin Kuster <akuster808@gmail.com>2020-09-02 21:22:16 -0700
commita6adc08626ec33dc1fc37316654988e51685a266 (patch)
tree5071bd8e69ffa28d60a622896ad04a147fb9b337
parent6a8d6ddc549638bed6dbf1d91df146b8a69ca589 (diff)
downloadmeta-openembedded-contrib-a6adc08626ec33dc1fc37316654988e51685a266.tar.gz
gnome-settings-daemon: Backport 3.36 fix for building without wayland
/usr/src/debug/gnome-settings-daemon/3.34.2-r0/build/../gnome-settings-daemon-3.34.2/plugins/wacom/gsd-wacom-manager.c:195: undefined reference to `gdk_wayland_device_get_node_path' Signed-off-by: Adrian Bunk <bunk@stusta.de> [AK: hand applied] Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-plugins-wacom-Fix-build-without-WAYLAND.patch27
-rw-r--r--meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.2.bb2
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-plugins-wacom-Fix-build-without-WAYLAND.patch b/meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-plugins-wacom-Fix-build-without-WAYLAND.patch
new file mode 100644
index 0000000000..d84fa984e5
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-plugins-wacom-Fix-build-without-WAYLAND.patch
@@ -0,0 +1,27 @@
+From ec6982cc8b3fccc35dbd5df3c4e22ab94709c66d Mon Sep 17 00:00:00 2001
+From: Vlad Banea <vlb@xiphos.ca>
+Date: Tue, 31 Dec 2019 15:35:41 -0500
+Subject: plugins/wacom: Fix build without WAYLAND
+
+Upstream-Status: Backport
+Signed-off-by: Adrian Bunk <bunk@stusta.de>
+---
+ plugins/wacom/gsd-wacom-manager.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plugins/wacom/gsd-wacom-manager.c b/plugins/wacom/gsd-wacom-manager.c
+index e1c8eaa7..92fd96c3 100644
+--- a/plugins/wacom/gsd-wacom-manager.c
++++ b/plugins/wacom/gsd-wacom-manager.c
+@@ -190,7 +190,7 @@ gsd_wacom_manager_class_init (GsdWacomManagerClass *klass)
+ static gchar *
+ get_device_path (GdkDevice *device)
+ {
+-#ifdef HAVE_WAYLAND
++#if HAVE_WAYLAND
+ if (gnome_settings_is_wayland ())
+ return g_strdup (gdk_wayland_device_get_node_path (device));
+ else
+--
+2.20.1
+
diff --git a/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.2.bb b/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.2.bb
index 0b6865d293..e2fbcb401d 100644
--- a/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.2.bb
+++ b/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.2.bb
@@ -31,6 +31,8 @@ UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
SRC_URI[archive.md5sum] = "493332fa0f36645188468fed41c0060b"
SRC_URI[archive.sha256sum] = "9fbae67e217e53b99e4f9e7d392c91ffbe31253941c9b136ef09c2d9db7ad7ed"
+SRC_URI += "file://0001-plugins-wacom-Fix-build-without-WAYLAND.patch"
+
# allow cross build mixed with build of native tools
do_write_config_append() {
cat >${WORKDIR}/meson.native <<EOF