aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Kroon <jacob.kroon@gmail.com>2020-06-10 21:49:01 +0200
committerKhem Raj <raj.khem@gmail.com>2020-06-10 20:57:01 -0700
commite921a2f251a325aaa1ea46c42b8ae789c2897cf0 (patch)
treeab6b9a1e884b5e41218c85ec3786b2eeecb664db
parentb2dfc24fdea7c3542dcb1118d12ed365390483c0 (diff)
downloadmeta-openembedded-contrib-e921a2f251a325aaa1ea46c42b8ae789c2897cf0.tar.gz
meta-oe: Don't inherit 'features_check' in recipes that don't utilize it
Signed-off-by: Jacob Kroon <jacob.kroon@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/transmission/transmission_git.bb2
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit_1.3.5.bb2
-rw-r--r--meta-oe/recipes-support/upower/upower_0.99.11.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/transmission/transmission_git.bb b/meta-oe/recipes-connectivity/transmission/transmission_git.bb
index ee5578f8b9..412bd9d3fa 100644
--- a/meta-oe/recipes-connectivity/transmission/transmission_git.bb
+++ b/meta-oe/recipes-connectivity/transmission/transmission_git.bb
@@ -19,7 +19,7 @@ PV = "2.94"
S = "${WORKDIR}/git"
-inherit autotools gettext update-rc.d systemd mime-xdg features_check
+inherit autotools gettext update-rc.d systemd mime-xdg
PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_1.3.5.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_1.3.5.bb
index 06895a03aa..21d13ac935 100644
--- a/meta-oe/recipes-extended/fluentbit/fluentbit_1.3.5.bb
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit_1.3.5.bb
@@ -52,7 +52,7 @@ EXTRA_OECMAKE_append_riscv64 = " -DFLB_DEPS='atomic'"
# DEPENDS += "openssl "
# EXTRA_OECMAKE += "-DFLB_OUT_KAFKA=On "
-inherit cmake systemd features_check
+inherit cmake systemd
SYSTEMD_SERVICE_${PN} = "td-agent-bit.service"
TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}"
diff --git a/meta-oe/recipes-support/upower/upower_0.99.11.bb b/meta-oe/recipes-support/upower/upower_0.99.11.bb
index 6408417920..d6c89a65d0 100644
--- a/meta-oe/recipes-support/upower/upower_0.99.11.bb
+++ b/meta-oe/recipes-support/upower/upower_0.99.11.bb
@@ -10,7 +10,7 @@ SRC_URI = " \
SRC_URI[md5sum] = "abe6acb617f11f2e8dbd9846fcf86e24"
SRC_URI[sha256sum] = "64b5ffbfccd5bdb15d925777979a4dbee1a957f9eaeb158dc76175267eddbdef"
-inherit autotools pkgconfig gettext gobject-introspection systemd features_check
+inherit autotools pkgconfig gettext gobject-introspection systemd
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"