aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2024-04-30 16:53:08 +0800
committerArmin Kuster <akuster808@gmail.com>2024-05-14 07:39:03 -0400
commitd64a161d5d93c79b1fbca71314b669485a1bae4e (patch)
treec0f688990d5f92c7f71bb3b618c882f205db43cf
parent01ea317089e1423a714aa439611a635c1a913525 (diff)
downloadmeta-openembedded-contrib-d64a161d5d93c79b1fbca71314b669485a1bae4e.tar.gz
python3-pyyaml-include: Drop pytest --automake
The python3-unittest-automake-output is not supported [1], so drop "pytest --automake". [1] https://lore.kernel.org/all/20240327072236.2221619-1-mingli.yu@windriver.com/T/#mda91919809cf156aba24f099bef65142067cd318 Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb1
2 files changed, 1 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest b/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest
index 8d2017d39c..3385d68939 100755
--- a/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest --automake
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb b/meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb
index 6768e959f4..b60a0f9c89 100644
--- a/meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb
@@ -24,6 +24,5 @@ RDEPENDS:${PN} += " \
"
RDEPENDS:${PN}-ptest += " \
python3-pytest \
- python3-unittest-automake-output \
"