aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-23 07:47:52 -0700
committerArmin Kuster <akuster808@gmail.com>2022-05-03 06:49:07 -0700
commit0af5a288541b808005147e3b2ae58f99d148d35b (patch)
tree2259887dbb2204cb1c85d5d2b79d1bce61ff35b4
parent2acf451b1b661a32ad75eea0dbaa06ba45298c1c (diff)
downloadmeta-openembedded-contrib-0af5a288541b808005147e3b2ae58f99d148d35b.tar.gz
tcsh: Do not install symlinks into /bin with usrmerge
Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit e059bf5da05dd895ac5fde665f283022ad5c59d2) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb b/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb
index c4da5cd835..f7282bf1fd 100644
--- a/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb
+++ b/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb
@@ -27,8 +27,10 @@ do_install:append () {
oe_runmake install.man DESTDIR=${D}
install -d ${D}${base_bindir}
- ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh
- ln -s /usr/bin/tcsh ${D}${base_bindir}/csh
+ if ! ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
+ ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh
+ ln -s /usr/bin/tcsh ${D}${base_bindir}/csh
+ fi
install -d ${D}${sysconfdir}/csh/login.d
install -m 0644 ${S}/csh.cshrc ${S}/csh.login ${S}/csh.logout ${S}/complete.tcsh ${D}${sysconfdir}
install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el