aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-12-13 18:14:54 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-14 09:31:31 +0100
commitdef33b5a819276057a047713de05475e792f5a18 (patch)
tree2cf4879f87630b16c41bcf09d6939868f7da99d4
parent7210880fb3baf98739bf61f9ab55764d6e76f423 (diff)
downloadmeta-openembedded-contrib-def33b5a819276057a047713de05475e792f5a18.tar.gz
iotop: don't fail when site.py* does not exist
* also remove usr/share/share removal, it's taken care of in distutils.bbclass now Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/iotop/iotop_0.4.4.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/iotop/iotop_0.4.4.bb b/meta-oe/recipes-extended/iotop/iotop_0.4.4.bb
index 8be41af41b..3b8150be9b 100644
--- a/meta-oe/recipes-extended/iotop/iotop_0.4.4.bb
+++ b/meta-oe/recipes-extended/iotop/iotop_0.4.4.bb
@@ -4,6 +4,8 @@ DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \
a table of current I/O usage by processes on the system."
HOMEPAGE = "http://guichaz.free.fr/iotop/"
+PR = "r1"
+
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
@@ -14,9 +16,8 @@ SRC_URI[sha256sum] = "46f3279fb1a7dfc129b5d00950c6e8389e4aedeb58880e848b88d68648
inherit distutils
do_install_append() {
- rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo
- rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py
- [ -d ${D}${datadir}/share ] && rmdir ${D}${datadir}/share
+ rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
+ rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true
}
RDEPENDS_${PN} = "python-distutils python-curses python-textutils \