aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2021-03-11 08:56:27 +0800
committerArmin Kuster <akuster808@gmail.com>2021-07-26 16:04:47 -0700
commit11c1cd6bf5855d458da94c6c7291bbe985ac653a (patch)
tree2b173eeb17fc7dc54195fade67865fc14488d438
parent9982d7f27714485dad9e81120bd7bf860be558d5 (diff)
downloadmeta-openembedded-contrib-11c1cd6bf5855d458da94c6c7291bbe985ac653a.tar.gz
php: allow php as empty
Since commit c4ffcaa2[php: split out phpdbg into a separate package], package php is empty, we might met error: nothing provides php needed by php-cli-7.4.9-r0.corei7_64 Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 9be6b4f5a2ec857475626c74457a94b8d9236fd5) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/php/php_7.4.9.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/php/php_7.4.9.bb b/meta-oe/recipes-devtools/php/php_7.4.9.bb
index 451c5e69f8..dd8404e688 100644
--- a/meta-oe/recipes-devtools/php/php_7.4.9.bb
+++ b/meta-oe/recipes-devtools/php/php_7.4.9.bb
@@ -213,6 +213,8 @@ RDEPENDS_${PN}-cli = "${PN}"
RDEPENDS_${PN}-modphp = "${PN} apache2"
RDEPENDS_${PN}-opcache = "${PN}"
+ALLOW_EMPTY_${PN} = "1"
+
INITSCRIPT_PACKAGES = "${PN}-fpm"
inherit update-rc.d